django创建超级用户是提示错误

李勇胜 发布于 2013/03/05 11:13
阅读 716
收藏 0

按照网上的教程,激活站点管理,使用syncdb之后自动询问是否建立超级用户,选择yes之后,提示报错,我当时连接的是MySQL数据库,错误为:Illegal mix of collations (gbk_chinese_ci,implicit) and (utf8_general_ci,coercible) for operation '='。这个问题搞得我进展不下去了,希望能够帮我解答一下。

系统为:windows7 32位 中文版

MySQL:5.5.27  数据库字符集为UTF8

加载中
0
10000011
10000011

数据库编码的问题,给你一个帖子你看看

http://blog.csdn.net/hi0000012345/article/details/6447846

李勇胜
李勇胜
回复 @ㄌ铭ㄜ : 这个我知道,可是还没办法啊
10000011
10000011
回复 @Freedom_7 :对啊 就是创建之后在工程名下面才有的啊!
Linktime
Linktime
回复 @李勇胜 : 你用django-admin.py createproject projectname 的时候,进入project目录,里边不是有一个manage.py 还有一个和project同名的文件夹么,settings.py就在里边啊,还有urls.py什么的
李勇胜
李勇胜
回复 @ㄌ铭ㄜ : 我没看到有settings.py这个文件呢……
10000011
10000011
回复 @李勇胜 :应该是同一个吧,你在看看,django安装成功会在 在python安装目录/Scripts 有!django-admin.py 。
下一页
返回顶部
顶部