ubuntu MySql停不掉

cgcgbcbc 发布于 2013/12/20 15:41
阅读 580
收藏 0

我试了以下三种方式,都不会报任何错,但是mysqld仍然在运行

sudo mysqld stop, mysqladmin -hlocalhost -uroot -p shutdown,sudo kill -9

前两个mysqld的pid不变,kill后换个pid仍然跑着

ps aux | grep mysql 只有mysqld在运行,没有mysql_safe

请问这是怎么原因导致的?还是说我被黑过了?

加载中
0
Scholer
Scholer
service mysql stop



Scholer
Scholer
回复 @cgcgbcbc : 哈哈 这种小错误很正常
cgcgbcbc
cgcgbcbc
突然发现输成service mysqld stop了。。。怪不得说未知任务
cgcgbcbc
cgcgbcbc
这个也试过了,是未知任务
0
eechen
eechen
停止MySQL服务:

sudo service mysql stop
查看MySQL进程:
top -n1 -b|grep mysqld

如果还没有停止,使用killall强行退出MySQL:
sudo killall mysqld

cgcgbcbc
cgcgbcbc
我刚刚试了这样来停止: sudo mv /usr/sbin/mysqld /usr/sbin/mysqld.bak sudo kill -9 <pid> 然后清静了 mysql -uroot -hlocalhost -p终于不能登录了。
0
OSC首席保安
OSC首席保安
估计是apt-get装的
0
记住一座城
记住一座城
你有没有修改过配置文件,如果配置文件有错,会出现这样的问题。
0
z
zx32342342

停止方式错误了吧, 我碰到过的停不掉的是mac下, 因为放到LaunchAgents了, 所以直接干掉后系统还会自动启动.... 所以我现在都是手动控制....

0
eechen
eechen
为了安全,还是建议你开启防火墙ufw(底层还是iptables):

sudo ufw enable
sudo ufw default deny
sudo ufw allow 22/tcp
sudo ufw allow 80/tcp
VPS的话要开放ssh的22端口和http的80端口,个人电脑就不需要了。

返回顶部
顶部