项目在Intellij idea 2.5能运行,但Intellij idea 3不能运行

K哥 发布于 2016/10/27 12:41
阅读 288
收藏 0
原来在Intellij idea 2.5里能正常运行的项目,到Intellij idea 3 公开预览版这个版本里怎么就不能正常运行了呢?报jdk版本过低的错,这是怎么回事?
Error:Internal error: (java.lang.UnsupportedClassVersionError) org/jetbrains/jps/android/model/impl/JpsAndroidModelSerializerExtension : Unsupported major.minor version 52.0
java.lang.UnsupportedClassVersionError: org/jetbrains/jps/android/model/impl/JpsAndroidModelSerializerExtension : Unsupported major.minor version 52.0

以下是问题补充:

@K哥:我知道是说jdk版本过低,但这个好像与我项目无关吧。同样的代码,在2.5里用jdk1.7可以运行,但放到3里面用jdk1.7就不能运行了,报这个错。 (2016/10/27 14:12)
加载中
0
K哥
K哥

貌似是一个bug,临时解决方法是禁用 Android Support 插件。

https://youtrack.jetbrains.com/issue/IDEA-162589

a temporary solution - disabled plugin "Android Support"

0
szwx855
szwx855

1、用javap -verbose 你工程编译后的classname查看里面的前三行。

一般会有如下提示:

  minor version: 0
  major version: 49

2.参考如下表

3、你这个 错误是因为,你1.7运行1.8的项目。不报错才怪。

返回顶部
顶部