Hyperic HQ 4.6 新功能介绍

liuyifeng 发布于 2011/08/10 15:25
阅读 1K+
收藏 0

  Hyperic HQ 4.6功能也适用于vFabric Hyperic 4.6.

详细参考原文:http://www.innovatedigital.com/node/691

1.产品插件的管理和部署

Hyperic4.6提供了新的功能,使部署的过程和管理产品插件变得很容易。这些功能包括一个用于管理产品插件的用户界面,以及新的Hyperic Server和Hyperic Agent,确保跨越Hyperic环境的一致的插件部署。

在以下各段简要介绍了新的插件管理功能。如需详细资讯,请参阅插件的部署和管理。

2.插件管理器 Plugin Manager

插件管理器是一个新的用户界面,使您能够部署和管理整个Hyperic用户界面的Hyperic部署插件。您可以使用插件管理器部署和移除Hyperic服务器的插件和所有代理到服务器的报告。

3.服务器与代理插件同步

新的服务器代理插件同步(SAPS)功能,确保产品插件统一部署Hyperic。 SAPS,是Hyperic服务器和Hyperic代理启用的新功能。当的Hyperic4.6代理启动时,它发送一个插件状态报告给Hyperic服务器。如果代理的部署插件不完全匹配Hyperic服务器上的部署,服务器适当更新代理的插件。同样,每次重新启动Hyperic服务器时,开始比较产品插件,发布最新的插件状态报告给每个代理 - 如果代理的部署插件不完全匹配的Hyperic的服务器,服务器适当更新部署的代理的插件。 SAPS,是默认启用的,它可以被禁用在server.pluginsync.enable的服务器属性,如下所述。

4.Hyperic服务器新属性,启用和禁用SAP

Hyperic 4.6提供了一个新的Hyperic服务器属性,server.pluginsync.enable,您可以使用禁用的SAPS,在上一节中描述的功能。要禁用SAPS,需要添加server.pluginsync.enable=false 到 ServerHome/conf/hq-server.conf文件,并重新启动Hyperic服务器。

5.必需的插件描述符元素支持SAPS

Hyperic4.6所有产品插件必须有一个版本。插件版本必须在产品插件的XML描述为根<plugin> 元素里指定一个<property>的元素。

6.安全性更改

下面段落简要总结Hyperic4.6的新的和更改的安全功能。如需详细资讯,请参阅Hyperic的安全特性和建议。

(1)密钥库

如果您使用SSL agent-to-server的通信,您可以使用信任的来自证书授权机构的SSL证书,或Hyperic产生一个自签名的证书。 Hyperic建议您为Hyperic4.6服务器的Hyperic4.6代理配置用户管理密钥库。使用未经认证的证书,减少Hyperic环境的安全。

对一个更安全的环境,只运行Hyperic 4.6代理和Hyperic4.6服务器就可以了。

(2)服务器密钥库

在Hyperic 4.6,对于完整安装,安装程序会提示您是否要为Hyperic服务器配置一个用户管理的密钥库。

如果你回答“yes”,安装程序将提示您提供的keystore的路径和密码。

如果你回答“no”,安装程序将创建一个服务器的密钥库,和一个自签名的证书。

对于升级安装,安装程序不提示您是否要为Hyperic服务器配置用户管理的密钥库。为了与Hyperic 4.6 之前的代理相兼容,安装程序会自动创建一个服务器的密钥库和自签名的证书。

在服务器上配置用户管理密钥库的位置和密码属性是server.keystore.path和server.keystore.password, 在ServerHome/conf/hq-server.conf文件。

(3)代理密钥库

默认情况下,Hyperic 4.6代理在第一次启动时用一个自签名的证书创建自己的密钥库。要为代理配置用户管理的密钥库,您必须在agent.properties文件中指定该密钥库的路径和密码。

在代理上配置用户管理的密钥库,位置和密码属性是agent.keystore.path and agent.keystore.password,在AgentHome/conf/agent.properties文件里。

(4)证书验证

如果服务器提供了一个未经证实的证书给4.6代理,该代理警告说,Hyperic Server主机的真实性不能成立,并提示确认连接,并导入证书。

同样,如果一个4.6代理提供了一个未经验证的证书给4.6服务器,服务器会发出一个警告,并进行确认提示,并继续下面。

(5)升级注意事项

Hyperic服务器和所有的Hyperic代理商升级为4.6的指导说明被提供在Hyperic4.6的升级过程和选项。

请注意,如果您使用Hyperic的产品插件,跟被管理服务器通过SSL进行通信,它可能是必要的,将管理服务器的SSL证书导入到Hyperic代理的keystore。

7.iPad和iPhone支持

Hyperic 4.6用户界面可以被iPad和iPhone访问.

8.更新的插件

已经更新了所有的Hyperic插件的XML描述,使用名为“version”的 元素,定义插件版本。

此外,以下的Hyperic插件更新了新功能,或支持管理产品的最新版本:

GemFire - 这个插件已经更新,以支持上述安全性更改的安全更新。  

      RabbitMQ- Hyperic4.6,RabbitMQ插件不再需要访问erlang.cookie文件 - 插件现在使用rabbitmq-management插件。配置过程中和可用的额外的度量值参数均发生了改变。此外,这个插件已经更新,以支持上述安全性更改的安全更新。 

      vSphere - 这个插件已经更新,以支持上述安全性更改的安全更新。  

      tc Server - 添加支持TC Server 7.0。  

      Jboss - 添加支持为JBoss 5.1和6.0。  

      PostgreSQL - 添加了对PostgreSQL 9.0的支持。  

      WebSphere WebLogic Server的插件 - Hyperic4.6,增强了管理WebLogic Server的插件,使节点管理和管理服务器在WebLogic域中启用了自动发现,而无需访问域管理服务器。在以前的版本,它是必要的,发现域的管理服务器,然后配置WebLogic Server凭据的资源,以便及时发现节点管理器和管理域中的服务器。

9.HQApi更新

Hyperic4.6包括HQApi 5.0。变更内容包括:

client.properties - 在5.0 HQApi,client.properties支持加密的密码,并可以存储或者~/.hq或hqapi1-client-nnn/conf。在以前的版本中,API在 ~/.hq/client.properties查找服务器连接属性;在不同的位置,使用连接属性,必须在命令行为client.properties连接属性提供路径,(提供在命令行上的属性文件的位置仍然支持。)对于在一个文件中指定连接属性的详细信息,请参阅HQApi命令行工具

groovyshell - 这个新的API允许你在命令行运行Groovy脚本。

维护 - 这个API更新,使个别资源调度计划维护宕机。在以前的版本中,只能维护一组资源的调度。

10.文件打包和发布

Hyperic 4.6建立了完整的vFabric Hyperic的文档设置,在Hyperic用户界面可以通过点击页面上的任何帮助访问。 Hyperic服务器选项,连接帮助内容到Hyperic的技术支持网站(http://support.hyperic.com),被从Hyperic4.6删除了。 (在以前的Hyperic发行版中,仅有用户界面的帮助页面,被以产品形式打包,并在HQ服务器设置页上的有一个配置选项切换产品内部的帮助和来自http://support.hyperic.COM的帮助。

在VMware vFabric 5 G.A以后,vFabric Hyperic4.6文档,包括可下载的PDF文件,在http://www.vmware.com/support/pubs/vfabric-hyperic.html可以找到,这个网址也是今后将公布Hyperic文档的地方。 Hyperic的技术支持网站上,vFabric 4.6和更高版本的文档将不被维护。

详细参考原文:http://www.innovatedigital.com/node/691

返回顶部
顶部