springside的quickstart编译错误

何必呢 发布于 2012/12/28 16:46
阅读 1K+
收藏 0

我下了springside-4.0.0.RC5-SP2之后运行quick-start.bat,showcase可以正常编译运行,quickstart编译报错,截取日志中部分错误如下:

2012-12-28 16:31:58,203 [main] ERROR [org.springframework.web.context.ContextLoader] - Context initialization failed
org.springframework.beans.factory.BeanDefinitionStoreException: Unexpected exception parsing XML document from URL [file:/F:/Driver/springside-4.0.0.RC5-SP2/examples/quickstart/target/classes/applicationContext.xml]; nested exception is org.springframework.beans.FatalBeanException: Invalid NamespaceHandler class [org.springframework.data.jpa.repository.config.JpaRepositoryNameSpaceHandler] for namespace [http://www.springframework.org/schema/data/jpa]: problem with handler class file or dependent class; nested exception is java.lang.NoClassDefFoundError: org/springframework/aop/framework/AbstractAdvisingBeanPostProcessor

我在下载的包里也没找到bstractAdvisingBeanPostProcessor相关文件啊,这个应该怎么解决?

加载中
0
何必呢
何必呢

这里人气不高啊,花了半天时间自己解决了,还是有些东西没下载下来,改了下settings.xml通过私服下载后编译成功。

0
四灭
四灭

我也遇到这个问题,但是后续还是继续出现问题。

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.
0:compile (default-compile) on project springside-test: Fatal error compiling: C
ompilerException: IllegalArgumentException: Illegal character in path at index 1
7: jar:/C:/Documents and Settings/Administrator/.m2/repository/org/springframewo
rk/spring-test/3.1.3.RELEASE/spring-test-3.1.3.RELEASE.jar!org/springframework/t
est/context/junit4/AbstractJUnit4SpringContextTests.class -> [Help 1]

有什么高招

0
flyoung
flyoung

这个问题根源 请看这里http://forum.springsource.org/showthread.php?132111-problem-today-Spring-Data-JPA-Exception

把spring版本换成3.2就没问题了

返回顶部
顶部