springboot中文乱码

wslk857208 发布于 2015/11/24 14:20
阅读 13K+
收藏 0

springboot 1.3在responseBody的时候中文全是问号

响应头已经是UTF-8了

加载中
1
beyondforever68
beyondforever68
默认就是utf8了,代码是utf8的吗
贝勒贝勒
贝勒贝勒
回复 @wslk857208 : 这个和java文件的保存格式有关
beyondforever68
beyondforever68
@wslk857208 我之前做的时候好像也没设置什么东西,直接就是正常的
wslk857208
wslk857208
这个和代码有关么?代码也是utf-8的
1
我的主页6
我的主页6

在pom.xml中添加下面两行

<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
<project.reporting.outputEncoding>UTF-8</project.reporting.outputEncoding>

0
wslk857208
wslk857208
额没有人呢吗
0
肩胛骨粉碎机
肩胛骨粉碎机
同问啊,百度居然没找到任何相关的解决方案
0
tandalys
tandalys
@RestController
@EnableAutoConfiguration
@RequestMapping(value = "/", produces = "application/json; charset=utf-8")
public class hello {
 @RequestMapping("/")
 public String home() {
   return "Hisdfds士大夫";
 }

 public static void main(String[] args) {
   SpringApplication.run(hello.class, args);
 }
}
三眼卡夫卡
三眼卡夫卡
大赞!
0
观嵩
观嵩
你怎么解决?
0
张治志
张治志

解决方案:

gradle中的编码要和java文件的编码一致才行。

1、首先看你的java文件编码字符集

如果为GBK,gradle设置如下:

tasks.withType(JavaCompile) {

  options.encoding ="GBK"

}

如果为UTF-8,gradle设置如下:

tasks.withType(JavaCompile) {

  options.encoding ="UTF-8"

}


0
小豪哥哥丶
可以体验一下魔方网表,没有乱码的。都是表与表之间的关系建立的。
0
s
sun135277
在spring boot配置文件中增加spring.http.encoding.force=true这个配置项即可
0
h
hellotrms

楼主,这个问题解决了吗?

spring.http.encoding.force=true 配置无用

produces = "application/json; charset=utf-8" 配置无用

你是怎么解决的?

返回顶部
顶部