Linux Mint 无法用锐捷联网

wffger 发布于 2012/12/14 19:57
阅读 2K+
收藏 1

@1inus 你好,想跟你请教个问题:

校园网认证客户端程序 For Linux版本安装指引:
软件说明:
本软件为绿色软件,命令行格式,解压后即可使用。
使用说明:
解压后,使用终端进入当前根目录,运行rjsupplicant.sh脚本即可启动RG-SU。
如果rjsupplicant.sh 脚本无法运行(非可执行文件),请运行以下命令: "sudo chmod +x ./rjsupplicant.sh"
第一次使用时,可以通过 --help命令查看使用帮助文档。
当客户端以后台模式运行时,输出运行日志(--help可查看),正常情况下,直接打印在终端无运行日志。
安装:
无需安装,解压tar包后,直接使用
卸载:
直接删除软件目录

代码:

#! /bin/bash

curDir=$(cd "$(dirname "$0")"; pwd);
arg="";
until [ $# -eq 0 ]
do
opt=$1;
if [ "${opt/ /}" != "$opt" ]; then
arg="$arg \"$opt\"";
else
arg="$arg $opt";
fi
shift
done

function is64BIT()
{
os=$(getconf LONG_BIT);
if [ $os != "64" ];  then
return 0;
fi
return 1;
}

function main()
{
is64BIT;
if [ $? != "1" ];  then
chmod +x $curDir/x86/rjsupplicant 2>&-;
cd $curDir/x86/
sh -c "$curDir/x86/rjsupplicant $arg";
else
chmod +x $curDir/x64/rjsupplicant 2>&-;
cd $curDir/x64/
sh -c "$curDir/x64/rjsupplicant $arg";
fi

}
main;
exit 0;

按照上面说的照做,完全没有用

sh rjsupplicant.sh

rjsupplicant.sh:16 rjsupplicant.sh: Syntax error: "(" unexpected

加载中
0
骠骑将军
骠骑将军

rjsupplicant.sh:16 rjsupplicant.sh: Syntax error: "(" unexpected

第十六行貌似有语法错误

用vim打开看看是不是多了(或者少了)

wffger
wffger
没有错误的
0
lightning1141
火耳
火耳
你需要先下载下来吧,安装上再连接网络。可以从同学的电脑上下个 .deb 包,安装即可。
wffger
wffger
MentoHUST安装时是需要联网的~~本来就上不了网啊~~
0
雨翔河
雨翔河
mentohust安装不需要联网,我现在就是mentohust认证,Ubuntu12.04。锐捷的坑爹玩意儿...我可以给你我自己写的说明书和网络上收集的安装包...
雨翔河
雨翔河
回复 @WFFGER : 真心不需要,那个8021的东西去同学那里复制一个就行了,然后那个包在我法给你的文件里面有。不需要什么东西了。
wffger
wffger
无法直接安装,还要联网下载其他四个软件
雨翔河
雨翔河
回复 @WFFGER : 已发送,记得查看邮箱。
wffger
wffger
你发到我邮箱wenfei182@163.com,谢谢
0
水牛叔叔
水牛叔叔
不好意思,现在才看到。这个问题我不懂,我没装过锐捷
0
明月照大江
明月照大江
  你看看一下,是不是缺少了什么必须的包,比如编译器,最后看一下64位和32位的问题
0
dreamers
dreamers
用mentohust。哈哈。我用它在fedora, centos, linux mint, gentoo, archlinux, 等 都可以连拉。
dreamers
dreamers
@WFFGER 能用就行...
wffger
wffger
我用的是LinuxMint14,请问我该下载哪个版本的?mentohust很久都没更新啊~~
0
沧浪淼客
沧浪淼客
用mentohust啊~~~
沧浪淼客
沧浪淼客
哦~~可能几个月前学校用的锐捷比较旧吧~~现在换成城市热点了,折腾折腾也可以上网……
wffger
wffger
mentohust木有更新啊...
0
未央lara
未央lara
楼主你好,请问最后你的mint用锐捷连上网没?我遇到了同样的问题,也有些锐捷客户端不能用,目前还没有弄好。
0
xtl1945
xtl1945

引用来自“未央lara”的评论

楼主你好,请问最后你的mint用锐捷连上网没?我遇到了同样的问题,也有些锐捷客户端不能用,目前还没有弄好。

艹!!3年前的帖子都给翻出来了!

不过,当年认证成功了!当时我认证失败的原因是命令错误。

看这个帖子:http://tieba.baidu.com/p/2782308819

OSCHINA
登录后可查看更多优质内容
返回顶部
顶部