libmemcache 如何在windows中安装(很急!!!)

mickey_52 发布于 2012/12/20 10:22
阅读 2K+
收藏 0
通过打开libmemcached-1.0.14中的 README.win32 的说明,如下:
So you want to know how to build libmemcached on Windows? In order to
have a single build environment you need to install mingw to get a
"unix environment" to run the configure script.

An easy way to get started is to install the msysgit fullinstall
package from: http://code.google.com/p/msysgit/downloads/list

msysgit does not contain the "autotools" needed to generate a
configure script, so you need to generate that on another box (this
should not be a problem if you're trying to build from a tar archive).

msysgit does not contain the tools to build the documentation, so you
need to add --without-docs to configure.

I'm normally building libmemcached with:

Ex:
$ ./configure --without-docs --with-memcached=../memcached/memcached.exe
$ make all install

libmemcached-1.0.14的下载地址:http://download.tangent.org/libmemcached-1.0.14.tar.gz
msysgit fullinstall package 下载地址:http://code.google.com/p/msysgit/downloads/list
http://211.162.127.23/download/2 ... preview20121022.exe

1.下载并解压好libmemcached-1.0.14
2.下载并安装msysgit 
3.运行msys.bat 
4.进入libmemcached-1.0.14的目录
$ cd  libmemcached-1.0.14
$ ./configure --without-docs --with-memcached
$make all install

结果出错了,请高手指点一把~
加载中
0
bcui6611
bcui6611
Post your error message first as detail as possible.
0
Le_Guto
Le_Guto
在window下编译比较麻烦 少一大堆库 ----
0
mickey_52
mickey_52

引用来自“李珍珍”的答案

在window下编译比较麻烦 少一大堆库 ----
我感觉是没有用到说明文档中的这一段话:
msysgit does not contain the "autotools" needed to generate a
configure script, so you need to generate that on another box (this
should not be a problem if you're trying to build from a tar archive).
对这一句话不是很理解,所以就忽略了这个步骤
0
mickey_52
mickey_52

引用来自“bcui6611”的答案

Post your error message first as detail as possible.
erro like : ./libmemcached-1.0/struct/sasl.h:39:23: error sasl/sasl.h :No such file or directory

                ./libmemcached-1.0/struct/sasl.h:47: error ISO C++ forbids declaration of 'sasl_callback_t' with notype ....

I think i just not understanding the text of 

msysgit does not contain the "autotools" needed to generate a
configure script, so you need to generate that on another box (this
should not be a problem if you're trying to build from a tar archive).

can you help me? thank you very much!

0
大田元山人
大田元山人

你好,请问你的问题解决了吗?我现在也在纠结如何在windows下安装libmemcached

m
mickey_51
还没的,我已经弃用这个东西了。
返回顶部
顶部