phpmyadmin在最新linux php5.3.8中竟然用不了

qycms_cn 发布于 2011/10/18 15:58
阅读 905
收藏 0
phpmyadmin(3.4.6),不管是最新版,还是旧版,在最新linux php5.3.8中竟然用不了。

查了一下,发现$GLOBAL这个全局在php5.3.8中和php5.2*中不太一样,
如何处理?
加载中
0
加咧个油
加咧个油
尝试下修改php session的用户、读写权限
0
sniperBlank
sniperBlank
什么错误?
0
qycms_cn
qycms_cn
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang=" Fatal error: Cannot use string offset as an array in /var/www/www.job2299.com/phpMyAdmin346/libraries/header_meta_style.inc.php on line 36 

header_meta_style.inc.php文件中,36行代码如下:
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="<?php echo $GLOBALS['available_languages'][$GLOBALS['lang']][1]; ?>" lang="<?php echo $GLOBALS['available_languages'][$GLOBALS['lang']][1]; ?>" dir="<?php echo $GLOBALS['text_dir']; ?>">

我尝试输出var_dump($GLOBALS); 结果如下:string(34) "l/themes/pmahomme/img/item_ltr.png
0
xyz555
xyz555
这个没可能吧, $GLOBALS是预定义变量,不能选择的,用phpinfo()查看一下安装或是配置对不对。我输出了一下5.3.8没问题。
0
mark35
mark35
多半是设置问题~
返回顶部
顶部