使用的graphite,为什么访问的时候总出现Apps aren't loaded yet这个错误?

洒洒 发布于 2016/04/28 19:17
阅读 1K+
收藏 0
Traceback (most recent call last):
  File "/usr/local/python2.7/lib/python2.7/site-packages/django/core/handlers/wsgi.py", line 158, in __call__
    self.load_middleware()
  File "/usr/local/python2.7/lib/python2.7/site-packages/django/core/handlers/base.py", line 51, in load_middleware
    mw_class = import_string(middleware_path)
  File "/usr/local/python2.7/lib/python2.7/site-packages/django/utils/module_loading.py", line 20, in import_string
    module = import_module(module_path)
  File "/usr/local/python2.7/lib/python2.7/importlib/__init__.py", line 37, in import_module
    __import__(name)
  File "/usr/local/python2.7/lib/python2.7/site-packages/django/contrib/auth/middleware.py", line 3, in <module>
    from django.contrib.auth.backends import RemoteUserBackend
  File "/usr/local/python2.7/lib/python2.7/site-packages/django/contrib/auth/backends.py", line 4, in <module>
    from django.contrib.auth.models import Permission
  File "/usr/local/python2.7/lib/python2.7/site-packages/django/contrib/auth/models.py", line 4, in <module>
    from django.contrib.auth.base_user import AbstractBaseUser, BaseUserManager
  File "/usr/local/python2.7/lib/python2.7/site-packages/django/contrib/auth/base_user.py", line 49, in <module>
    class AbstractBaseUser(models.Model):
  File "/usr/local/python2.7/lib/python2.7/site-packages/django/db/models/base.py", line 94, in __new__
    app_config = apps.get_containing_app_config(module)
  File "/usr/local/python2.7/lib/python2.7/site-packages/django/apps/registry.py", line 243, in get_containing_app_config
    subpath = object_name[len(app_config.name):]
  File "/usr/local/python2.7/lib/python2.7/site-packages/django/apps/registry.py", line 124, in check_apps_ready
    raise AppRegistryNotReady("Apps aren't loaded yet.")
django.core.exceptions.AppRegistryNotReady: Apps aren't loaded yet.

[pid: 5018|app: 0|req: 11/11] 127.0.0.1 () {40 vars in 662 bytes} [Thu Apr 28 11:11:01 2016] GET / => generated 0 bytes in 5 msecs (HTTP/1.1 500) 0 headers in 0 bytes (0 switches on core 0)


使用的graphite,为什么访问的时候总出现Apps aren't loaded yet这个错误?

加载中
返回顶部
顶部