apr编译安装时报错“configure: error: C compiler cannot create executables”

Crazy丶纸 发布于 2016/05/23 12:18
阅读 543
收藏 0
[root@Kry123 apr-1.5.2]# ./configure --prefix=/usr/local/apr
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
Configuring APR library
Platform: x86_64-unknown-linux-gnu
checking for working mkdir -p... yes
APR Version: 1.5.2
checking for chosen layout... apr
checking for gcc... gcc
checking whether the C compiler works... no
configure: error: in `/usr/local/src/apr-1.5.2':
configure: error: C compiler cannot create executables

See `config.log' for more details

[root@Kry123 apr-1.5.2]# rpm -qa  |grep gcc
gcc-c++-4.4.7-16.el6.x86_64
gcc-gfortran-4.4.7-16.el6.x86_64
libgcc-4.4.7-16.el6.x86_64
gcc-4.4.7-16.el6.x86_64
[root@Kry123 apr-1.5.2]# rpm -qa  |grep glibc 
glibc-common-2.12-1.166.el6_7.7.x86_64
glibc-headers-2.12-1.166.el6_7.7.x86_64
glibc-2.12-1.166.el6_7.7.x86_64
glibc-devel-2.12-1.166.el6_7.7.x86_64
[root@Kry123 apr-1.5.2]# rpm -qa  |grep libaio
libaio-0.3.107-10.el6.x86_64

[root@Kry123 apr-1.5.2]# rpm -qa  |grep glibc
glibc-common-2.12-1.166.el6_7.7.x86_64
glibc-headers-2.12-1.166.el6_7.7.x86_64
glibc-2.12-1.166.el6_7.7.x86_64
glibc-devel-2.12-1.166.el6_7.7.x86_64



加载中
返回顶部
顶部