mopaas部署nodejs出错,如何解决?

多多de棉花糖 发布于 2015/03/31 13:23
阅读 671
收藏 0

这是日志,nodejs 如何解决呀

====>logs/stderr.log<====

js-bson: Failed to load c++ bson extension, using pure JS version

/var/vcap.local/dea/apps/bodychat-0-82388ca0b28e55d344fdc18219609841/app/node_modules/express/node_modules/accepts/node_modules/mime-types/node_modules/mime-db/db.json:2
"application/1d-interleaved-parityfec": {
              ^

node.js:134
   throw e; // process.nextTick error, or 'error' event on first tick
   ^
SyntaxError: Unexpected token :
  at Module._compile (module.js:406:25)
  at Object..js (module.js:417:10)
  at Module.load (module.js:343:31)
  at Function._load (module.js:302:12)
  at require (module.js:355:19)
  at Object.<anonymous> (/var/vcap.local/dea/apps/bodychat-0-82388ca0b28e55d344fdc18219609841/app/node_modules/express/node_modules/accepts/node_modules/mime-types/node_modules/mime-db/index.js:11:18)
  at Module._compile (module.js:411:26)
  at Object..js (module.js:417:10)
  at Module.load (module.js:343:31)
  at Function._load (module.js:302:12)

====>logs/stdout.log<====
{ stack: [Getter/Setter],
arguments: undefined,
type: undefined,
message: '/lib/libc.so.6: version `GLIBC_2.14\' not found (required by /var/vcap.local/dea/apps/bodychat-0-82388ca0b28e55d344fdc18219609841/app/node_modules/bson/build/Release/bson.node)' }
加载中
0
mopaas
mopaas
v1的版本是0.3,v2的版本0.8.-0.11
c
cyj123
是node的版本吗?
0
c
cyj123

引用来自“mopaas”的评论

v1的版本是0.3,v2的版本0.8.-0.11
这是什么。。。。还v1 和 v2 ,能不能详细点,我也遇到相同问题
多多de棉花糖
多多de棉花糖
这是v1,版本低了
0
swgo
swgo

删掉bson-ext就行了

详细看我博客

http://heymind.leanote.com/post/%E5%9C%A8Mopaas%E9%83%A8%E7%BD%B2Nodejs

返回顶部
顶部