我的fedora在安装samba服务器时出现了如下问题,求解答

张昌明 发布于 2014/04/14 16:51
阅读 102
收藏 0
[root @localhost home]# rpm -ivh samba-3.0.4-0.5.1.i386.rpm
错误:依赖检测失败:
libacl.so.1 被 samba-3.0.4-0.5.1.i386 需要
libc.so.6 被 samba-3.0.4-0.5.1.i386 需要
libc.so.6(GLIBC_2.0) 被 samba-3.0.4-0.5.1.i386 需要
libc.so.6(GLIBC_2.1) 被 samba-3.0.4-0.5.1.i386 需要
libc.so.6(GLIBC_2.1.1) 被 samba-3.0.4-0.5.1.i386 需要
libc.so.6(GLIBC_2.1.3) 被 samba-3.0.4-0.5.1.i386 需要
libc.so.6(GLIBC_2.2) 被 samba-3.0.4-0.5.1.i386 需要
libc.so.6(GLIBC_2.2.3) 被 samba-3.0.4-0.5.1.i386 需要
libc.so.6(GLIBC_2.3) 被 samba-3.0.4-0.5.1.i386 需要
libcom_err.so.3 被 samba-3.0.4-0.5.1.i386 需要
libcrypt.so.1 被 samba-3.0.4-0.5.1.i386 需要
libcrypto.so.4 被 samba-3.0.4-0.5.1.i386 需要
libcups.so.2 被 samba-3.0.4-0.5.1.i386 需要
libdl.so.2 被 samba-3.0.4-0.5.1.i386 需要
libdl.so.2(GLIBC_2.0) 被 samba-3.0.4-0.5.1.i386 需要
libdl.so.2(GLIBC_2.1) 被 samba-3.0.4-0.5.1.i386 需要
libgssapi_krb5.so.2 被 samba-3.0.4-0.5.1.i386 需要
libk5crypto.so.3 被 samba-3.0.4-0.5.1.i386 需要
libkrb5.so.3 被 samba-3.0.4-0.5.1.i386 需要
liblber.so.2 被 samba-3.0.4-0.5.1.i386 需要
libldap.so.2 被 samba-3.0.4-0.5.1.i386 需要
libnsl.so.1 被 samba-3.0.4-0.5.1.i386 需要
libnsl.so.1(GLIBC_2.0) 被 samba-3.0.4-0.5.1.i386 需要
libpam.so.0 被 samba-3.0.4-0.5.1.i386 需要
libpopt.so.0 被 samba-3.0.4-0.5.1.i386 需要
libresolv.so.2 被 samba-3.0.4-0.5.1.i386 需要
libssl.so.4 被 samba-3.0.4-0.5.1.i386 需要
perl(Exporter) 被 samba-3.0.4-0.5.1.i386 需要

perl(strict) 被 samba-3.0.4-0.5.1.i386 需要

还望大牛给予详细指点




加载中
0
luecheng
luecheng
直接用yum安装自动解决依赖问题:yum install -y samba ,参数-y是直接确认安装,去掉要手动确认安装,在脚本自动化时加此参数避免交互。
张昌明
张昌明
回复 @张昌明 :问题已解决,谢谢喽
张昌明
张昌明
我用yum -y install samba 安装成功了,可是在etc/init.d/下面没有找到nmb,smb管理文件。。。
返回顶部
顶部