Maven 报错

奥神Well 发布于 2017/05/27 16:41
阅读 49
收藏 0

使用Maven引入依赖的jar包,但是报

Archive for required library XXX cannot be read or is not a valid ZIP file.

找了很多方案读都没有解决。  

加载中
0
奥神Well
奥神Well

解决了,对于一些jar包的版本,最好使用 Repository 为 Central , Usages 最多的。比如我用spring 4.2.1.REALEASE版本就不行,换成 4.2.9.REALEASE版本就OK了。这个还是要具体到每一个jar包,可以通过http://mvnrepository.com/ 这个系统查找你需要的jar包的版本的使用度。

0
polly
polly
去仓库里,把那个jar所在目录整个删掉,重新拉取
奥神Well
奥神Well
试过了,还是没有用。
返回顶部
顶部