grails3 idea

世尘悉洞 发布于 2015/11/11 15:04
阅读 637
收藏 0

各位大侠好,

    用IntelliJ IDEA15创建Grails3的工程,无法成功创建项目。提示的错误如下:

    用命令行也无法创建工程,错误如下:

请问哪位大虾使用过grails3的版本而且用得IDEA,麻烦指点一下。实在找不到问题了。之前用2.4的版本没有出现过这类问题。

加载中
0
soulsleep
soulsleep
maven仓库 被墙了吧?
0
世尘悉洞
世尘悉洞

引用来自“soulsleep”的评论

maven仓库 被墙了吧?
你现在也使用grails3了么?我是没有用过,所以才不知道什么情况,maven被墙了?我不知带grails3需要用啥maven。而且我本地maven仓库中也有jar包得。
世尘悉洞
世尘悉洞
回复 @soulsleep :本地仓库我配置了,这个环境其实我用grails2是没有问题的,但是切换到grails3就不知道什么地方有问题了。啥都不好用了。不行就只能在切换到grails2了
soulsleep
soulsleep
我一直用grails2 grails用的是gradle,也是maven的一种配置方式吧(个人理解) 虽然你有本地仓库但是没配吧 看看 源代码下的 build.gradle吧
0
Feng_Yu
Feng_Yu

我这边就没报错,而且create-app的时候是不需要下载任何东西的。看你的报错应该是文件不完整吧?重新下载试试?

多版本管理可以用sdkman

0
世尘悉洞
世尘悉洞

引用来自“Feng_Yu”的评论

我这边就没报错,而且create-app的时候是不需要下载任何东西的。看你的报错应该是文件不完整吧?重新下载试试?

多版本管理可以用sdkman

我用的就是sdkman,你用的版本是3.0.9么?
世尘悉洞
世尘悉洞
回复 @Feng_Yu : 我今天测试了,应该是我下载的包的问题,我新下载的包就没有问题了。感谢大虾
Feng_Yu
Feng_Yu
回复 @世尘悉洞 : sdkman判断是否失败是解压zip然后看unzip的返回码的。我读过sdkman的shell源码,以前还叫gvmtool的时候递交过pull request,只不过没通过,再后来因为和go version manager名字冲突(gvm),就改名sdkman了。通过解压判断是否安装成功不一定靠谱
世尘悉洞
世尘悉洞
回复 @Feng_Yu : 好的,我试试,我之前用sdkman下载的时候好像还真出现过失败的情况,然后从新装的,难道是这方面的问题?
Feng_Yu
Feng_Yu
回复 @世尘悉洞 :我试过了才回帖的。你可以试试把~/.sdkman下的grails/3.0.9删了,从grails官网下载grails-3.0.9.zip,扔到~/.sdkman/archives,然后sdk i grails重新安装一下再看看呢?
世尘悉洞
世尘悉洞
回复 @Feng_Yu : grails3目前idea15支持,之前的14是不支持的好像。我看很多人都问。GGST不太清楚能不能支持,我没用过。
下一页
0
w
weili0677
grails3 is compile with gradle now...
返回顶部
顶部