jQuery EasyUI IE8 兼容性问题

码农先生 发布于 2013/06/01 16:06
阅读 52K+
收藏 3

网页错误详细信息

用户代理: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Win64; x64; Trident/4.0; .NET CLR 2.0.50727; SLCC2; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0)
时间戳: Sat, 1 Jun 2013 07:52:07 UTC


消息: 'JSON' 未定义
行: 4
字符: 559
代码: 0
URI: http://127.0.0.1:8080/aom/plugins/jquery-easyui-1.3.3/jquery.min.js


消息: 'jQuery' 未定义
行: 12
字符: 1
代码: 0
URI: http://127.0.0.1:8080/aom/plugins/jquery-easyui-1.3.3/jquery.easyui.min.js


消息: '$' 未定义
行: 1
字符: 1
代码: 0
URI: http://127.0.0.1:8080/aom/plugins/jquery-easyui-1.3.3/locale/easyui-lang-zh_CN.js


消息: '$' 未定义
行: 51
字符: 1
代码: 0
URI: http://127.0.0.1:8080/aom/plugins/jquery-easyui-1.3.3/util/CustomChecking.js


消息: '$' 未定义
行: 1
字符: 1
代码: 0
URI: http://127.0.0.1:8080/aom/plugins/jquery-easyui-1.3.3/util/EasyuiUtil.js


消息: 缺少对象
行: 38
字符: 4
代码: 0
URI: http://127.0.0.1:8080/aom/

 

Firefox、Google正常,IE 10 也正常,就是IE8不行。。。

加载中
0
foxlee
foxlee
1.3.3内置是jquery2,不兼容低版本的ie,你更换到1.10试试!
码农先生
码农先生
一开始以为是jQuery版本问题,最后去官网下载了2.0,粘贴以后发现svm无动静,这才发现 EasyUI1.3.3 用的就是 jQuery 2.0 。。。
0
码农先生
码农先生
今天休息,貌似没人啊。。。
0
码农先生
码农先生
Easyui 1.3.3 直接就不支持 ie 8 了,现在换成了 1.3.2 ,之前都是用 google 、 ie 10 做开发的,现在也算是长个记性。。。
码农先生
码农先生
回复 @谭书记 : 直接把1.3.2解压后全部替换,还有,IE下JS缓存貌似很严重,清理下多刷新几次
一个不正经的程序员
一个不正经的程序员
回复 @码农先生 : 替换了也不行,呵呵。。把easyui的提交方式换了,就没问题啦
码农先生
码农先生
回复 @谭书记 : 直接删除别的版本,使用1.3.2的就替换成功了啊
一个不正经的程序员
一个不正经的程序员
请问下如何替换成1.3.2?我直接把1.3.2的easyui的js替换了还是不行、、、还要替换别的?
0
y
youlingken
这个适合做访问量很大的网站的首页不呢,谢谢。
码农先生
码农先生
去这儿先了解下吧:http://www.jeasyuicn.com/
0
gzxxy
gzxxy
这问题没人解决掉么,各位大神,求教
码农先生
码农先生
<br/>不知道你需不需要:<a href="http://sypro.jeasyuicn.com/" target="_blank">jQuery EasyUI 经典示例项目demo+源码下载</a>
码农先生
码农先生
解决了啊,你都不看评论啊? 是因为 jQuery EasyUI 1.3.2 之后版本的 jQuery 文件不支低版本IE浏览器,1.3.2 版本之后的都是 jQuery 2.0 版本。
0
PanFrey
PanFrey
jQuery Easy UI从1.3.3到现在的最新版本1.3.4都是基于jQuery2.0的,而jQuery2.0是不支持IE6、7、8的了,所以jQueryEasyUI1.3.3后的版本都不支持IE6、7、8。如果想继续兼容IE8以前的版本,只能使用jQueryEasyUI1.3.2或以前的版本了,但是可能得注意一些EasyUI的API可能会有差异。
码农先生
码农先生
回复 @谭书记 : 第三方超级扩展:http://www.cnblogs.com/cjw0511/p/3324082.html
码农先生
码农先生
回复 @上山打伞 : http://www.cnblogs.com/cjw0511/p/3324082.html
码农先生
码农先生
回复 @MiniBu : http://www.cnblogs.com/cjw0511/p/3324082.html
MiniBu
MiniBu
回复 @码农先生 : 同求第三方扩展包名
上山打伞
上山打伞
回复 @码农先生 : 能把第三方扩展包 名说出来吗?
下一页
0
crazymus
crazymus
原来如此,我也遇到这个问题了。
0
jianjin712
jianjin712
你看看核心文件jquery.min.js的版本号是否大于1.9的了,1.9之后的版本官方说不兼容ie8的了。
0
MiniBu
MiniBu
已经下载easyui 1.3.2 对应jQuery1.8 版本,可支持IE8及以下了。
MiniBu
MiniBu
回复 @码农先生 :嗯嗯 谢谢~
码农先生
码农先生
还在用的话可以看看这个EasyUI扩展:http://www.cnblogs.com/cjw0511/p/3324082.html
0
StreamWang
StreamWang
jquery支持ie8的最后一个版本版本号是多少?是1.11.1?
StreamWang
StreamWang
回复 @码农先生 : jQuery团队在2013放出了两个版本。第一个版本保持1.x的编号,目前1.11.1,其保持了最大数量的浏览器兼容。第二个版,从2.0.0到现在的2.1.1,为精简代码去除了对IE8以及以下浏览器的支持。正如之前,将有两个不同的发布文件。1.11.1的继承版本将成为jQuery Compat 3.0。jQuery 2.1.1的继承版本将为jQuery 3.0。
码农先生
码农先生
回复 @StreamWang : 你试试不就知道了-_-
StreamWang
StreamWang
@码农先生 1.8.3?
码农先生
码农先生
1.8
返回顶部
顶部