Subversion 1.6 版本的安装还真有些费劲啊

绿悠悠 发布于 2010/01/03 00:58
阅读 842
收藏 0

俺的Linux服务器(红帽子AS5)自带的 Subversion 版本1.4.2太低,今天把它升级到最新的 1.6.6 版本,其中麻烦不少。

1. 卸载的问题,请看这里
2. APR 和 APR-UTIL 的问题就不说了,装就是了
3. SQLite,Subversion 1.6.x 居然需要 SQLite 的支持,不过倒也省事,到 SQLite 网站上下载个最新版本的 SQLite。解压后将 sqlite3.c 文件复制到 subversion 解压后的目录下的 sqlite-amalgamation 子目录(此目录要自建)

接下来安装即可

./configure --with-apr=xxxx --with-apr-util=xxxx

加载中
0
万事通
万事通

  直接下载新版安装,省不少事。

返回顶部
顶部