要疯了,在mac上装个eclipse svn插件怎么这么难?

nick_chen 发布于 2013/03/24 14:33
阅读 11K+
收藏 0

【Gopher China万字分享】华为云的Go语言云原生实战经验!>>>

的我mac os是 10.8.3的版本,下载了eclipse juno,安装了subclipse 1.8.x,但是不能用,因为要安装javaHL,网上找了一整天的办法,大概是这样的:

1、安装xcode及xcode command line

2、安装MacPorts,并且update

3、执行如下命令:

sudo port install subversion-javahlbindings +no_bdb +universal

但是,执行时会报Building kerberos5失败的错误,然后就停止了,

错误信息如下:

Error: org.macports.build for port kerberos5 returned: command execution failed
Error: Failed to install kerberos5
Please see the log file for port kerberos5 for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_kerberos5/kerberos5/main.log
Error: The following dependencies were not installed: cyrus-sasl2 kerberos5 file junit hamcrest-core neon serf1 subversion curl-ca-bundle
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port subversion-javahlbindings failed
看样子是少了一些依赖的基础软件之类,我也查看了日志,也看了那个guide,但是还是没有解决的办法(英文,你懂的),谁能帮我?

加载中
0
ddatsh
ddatsh

不用macports改用brew 了我

不要纠结,选成JAVA实现就是了

ddatsh
ddatsh
是有点小慢 也不至于半小时吧
nick_chen
nick_chen
用brew到configure subversion时是很慢吗?这都半小时make不动了
0
明月照大江
明月照大江
用1.6的什么问题都没了,不要用1.8.我曾经在linux上纠结过,最后还是坚持使用1.6.1.8问题多还不好解决
ddatsh
ddatsh
绝对不用1.7以下了 恶心的分散.svn目录受不了
0
winnie_tour
winnie_tour
svn还难?装maven时候你就知道更难了。。
0
puras
puras

引用来自“winnie_tour”的答案

svn还难?装maven时候你就知道更难了。。
maven有啥问题?我这下载配一下就可以用了撒
0
nick_chen
nick_chen
多谢各位,我终于搞定了,subclipse1.8.x,怎么搞定的我也不确定,呵呵,但是用了brew代替了macports,javaHL正常安装了。
0
Simtice
Simtice

引用来自“nick_chen”的答案

多谢各位,我终于搞定了,subclipse1.8.x,怎么搞定的我也不确定,呵呵,但是用了brew代替了macports,javaHL正常安装了。
请问如何安装?我正也纠结这个问题,求教育
0
nick_chen
nick_chen

引用来自“Simtice”的答案

引用来自“nick_chen”的答案

多谢各位,我终于搞定了,subclipse1.8.x,怎么搞定的我也不确定,呵呵,但是用了brew代替了macports,javaHL正常安装了。
请问如何安装?我正也纠结这个问题,求教育

你可以查看我写的博客:http://my.oschina.net/u/866380/blog/117363

直接跳过macports部分,先用brew装好javaHL,然后在eclipse的marketplate里安装subclipse1.8.x即可。

0
hujinhu
hujinhu
同疯!…………现在正在brew装javaHL中。。
返回顶部
顶部