装ekho的过程中始终不能安装成功

fidelhuang 发布于 2012/10/26 12:26
阅读 1K+
收藏 0

@黄冠能 你好,想跟你请教个问题:

我们在安装ekho的过程中始终不能安装成功,能否指教下,谢谢!

 

configure: error: in `/root/soft/ekho-4.12':
configure: error: pulseaudio test failed (--without-pulseaudio to disable)
See `config.log' for more details

如果 --without-pulseaudio  
make 
报错


[root@ali05 ekho-4.12]# make
make  all-am
make[1]: Entering directory `/usr/local/src/ekho-4.12'
g++ -DHAVE_CONFIG_H -I.    -I./utfcpp/source -I./sonic    -I./sr-convert -DOUTPUT16BIT -D_`uname -p` -pthread -g -O2 -O0 -MT libekho_a-libekho.o -MD -MP -MF .deps/libekho_a-libekho.Tpo -c -o libekho_a-libekho.o `test -f 'src/libekho.cpp' || echo './'`src/libekho.cpp
In file included from /usr/lib/gcc/x86_64-redhat-linux/4.1.2/../../../../include/c++/4.1.2/backward/strstream:51,
                 from ./sr-convert/sr-convert.cpp:24,
                 from src/libekho.cpp:32:
/usr/lib/gcc/x86_64-redhat-linux/4.1.2/../../../../include/c++/4.1.2/backward/backward_warning.h:32:2: warning: #warning This file includes at least one deprecated or antiquated header. Please consider using one of the 32 headers found in section 17.4.1.2 of the C++ standard. Examples include substituting the <X> header for the <X.h> header for C++ includes, or <iostream> instead of the deprecated header <iostream.h>. To disable this warning use -Wno-deprecated.
src/phonetic_symbol.h: In member function 
const char* ekho::PhoneticSymbol::getPcm(const char*, const char*, int&, SF_INFO&):
src/phonetic_symbol.h:109: error: 
SF_FORMAT_VORBIS was not declared in this scope
src/libekho.cpp: In member function 
int ekho::Ekho::saveOgg(std::string, std::string):
src/libekho.cpp:289: error: 
SF_FORMAT_OGG was not declared in this scope
src/libekho.cpp:289: error: 
SF_FORMAT_VORBIS was not declared in this scope
make[1]: *** [libekho_a-libekho.o] Error 1
make[1]: Leaving directory `/usr/local/src/ekho-4.12'
make: *** [all] Error 2 

加载中
0
黄冠能
黄冠能

应该是个bug(我很少测试这个选项),已通过邮件发新得测试版给你,或者你可以checkout SVN版本试试。谢谢!

返回顶部
顶部