15
回答
帮忙解决安装Vbox共享时错误:disagrees about version of symbol
开发十年,就只剩下这套Java开发体系了   

系统是Centos5.5.一安装好后我就升级了kernel,变成了2.6.18-194

但是安装共享的那个包的时候就出现了这个错误,网上查是说内核版本不对,但是就是没看懂解决办法(一般都不是centos系统,有些命令咱没有,文件名字也不一样),我的linux水平太菜,只能过来求一通俗易懂的解决办法了。

举报
熊二哈
发帖于8年前 15回/894阅
共有15个答案 最后回答: 8年前

引用楼主的话:我的linux水平太菜,只能过来求一通俗易懂的解决办法了。

不信,如果水平太菜的人肯定不会去升级内核。

我是看别人升,我就跟着升了。升了内核什么好处都没有,反而搞出解决不了的问题,惭愧。!

引用来自#3楼“熊二傻”的帖子

我是看别人升,我就跟着升了。升了内核什么好处都没有,反而搞出解决不了的问题,惭愧。!

升级后原来的内核文件还在的阿,启动的时候选择原来的内核进去就行了

楼主用的是哪个内核呢

uname -a贴出来看看

假如是是kernel-xen的话,会和vmware,virtual box这些虚拟化软件冲突

但我看错误提示,是因为 LZ 没有安装 X windows 呢.. V box 依靠 X windows 的界面来设置虚拟机,没有的话弄不了呢。

而且照理来说,最新版的 CentOS, 内核版本都够用了,安装 V box 应该轻而易举的呢。

我本来已经装好一个Centos虚拟了.Vbox的共享文件夹也弄好的了

这是第二个Centos系统,这个地方居然出这个问题了

顶部