老问题找不到错Apache don't have permission to access

熊二哈 发布于 2010/06/11 18:42
阅读 1K+
收藏 3

 

错误:You don't have permission to access /zentaopms/ on this server.

我把httpd.conf 那些默认和制定目录/var/www/html的<Directory>标签下denny全注释了 还是不行。

我自己又新建了一个目录testdir,里面写index.html,可以访问。

但访问这个zentaopms这个目录就不行

文件权限都一样是drwxr-xr-x,一个目录下。

selinux的权限也一样都是httpd_sys_content_t。

我找不到地方了,很无语了。

 

请教大侠们,还有哪个地方能改改的?

加载中
0
张松

从你的话中和上边的图片不知道你用的什么系统,不够这多半是因为权限不够,这是肯定的,你可以将<directory>标签下的设置这么写, Order allow,deny
    Allow from all

在windows下这个写法是可以的,你可以试试。

0
来自杭州的小杨
来自杭州的小杨

改权限的话,有没有递归呢?

0
Gavin Hu
Gavin Hu

引用来自#2楼“张松”的帖子

从你的话中和上边的图片不知道你用的什么系统,不够这多半是因为权限不够,这是肯定的,你可以将标签下的设置这么写, Order allow,deny
    Allow from all

在windows下这个写法是可以的,你可以试试。

同意2楼的意见

0
范堡
范堡

哈哈哈...! LZ 你把Apache中该主机的配置贴上来.

很有可能是你Apache 配置中, 目录路径配置的最后多了个 "/ "

我当年就好像你这样郁闷过~!

<VirtualHost *:80>
    ServerAdmin qbanke@163.com
    DocumentRoot /data/web_server/someqone   (留意)
    ServerName  www.someqone.com
    ServerAlias www.someqone.com
<Directory "/data/web_server/someqone">     (留意)
    Options FollowSymLinks
    AllowOverride FileInfo
    Order allow,deny
    Allow from all
</Directory>
</VirtualHost>

0
开源春哥
开源春哥

呵呵,大家讨论的很火热嘛。

这个403的错误,我想可能是因为你访问的是/zentaopms/,而禅道的入口文件实际上是在zentaopms/www目录下面。apache估计是禁止了目录列表,所以你访问zentaopms会出现403的错误。可以试试访问/zentaopms/www/

或者可以修改DocumentRoot的设置,将其指到zentaopms/www所在的目录。

0
张林
张林

不会是linux系统吧?

0
熊二哈
熊二哈

谢谢大家的热心帮助,我的系统是centos.

Apache的配置等我用工具拿下来再贴。

0
熊二哈
熊二哈

找到问题的关键了。Zend权限有问题。

返回顶部
顶部