Ruby on rails 遇到 libmysqlclient 问题

王振威 发布于 2012/12/25 17:28
阅读 1K+
收藏 1

在使用bundle管理依赖的时候遇到了这个问题:

Make sure that `gem install mysql2 -v '0.3.11'` succeeds before bundling.

在搜索后发现需要安装:libmysql-ruby libmysqlclient-dev

由于我机器上安装的是percona server,结果出现了如下冲突:

The following packages have unmet dependencies:
 libmysqlclient-dev : Depends: libmysqlclient18 (= 5.5.28-0ubuntu0.12.04.3) but 5.5.20-rel24.1-217.lenny is to be installed
E: Unable to correct problems, you have held broken packages.

不想卸载percona server,有比较熟悉的给看看如何解决.

系统环境:ubuntu12.04 ruby1.9.3 percona server 5.5.20 

加载中
0
陈好
陈好
我也碰到这个问题了,不过我这是MariaDB,安装libmariadbclient-dev后正常
返回顶部
顶部