求助window 8环境安装express报错 error unknown option

markYun 发布于 2014/09/27 01:17
阅读 850
收藏 0

window 安装express  error  unknown option  ‘ -v’


以下是问题补充:

@markYun: node 和npm 安装成功了,express没安装成功,但提示是安装成功了, 然后我启动应用:Cannot find module 'express-scaffold' 报错。 (2014/09/27 01:31)
加载中
0
愤怒的小兔
愤怒的小兔
npm install -g express
npm install -g express-generator
#然后通过express -V查看版本,看好是大写的V



markYun
markYun
回复 @大熊兔先生 : 各种执行参数都试过了一次。是不是要先清除原来的操作: npm install express 执行了, 再执行一次 : npm install -g express 会覆盖原来的吗?
愤怒的小兔
愤怒的小兔
回复 @markYun : express-generator安装时是否忘记使用"-g"这个选项了?就是 npm install -g express-generator
markYun
markYun
回复 @大熊兔先生 : 继续报错:Cannot find module 'express-scaffold'
愤怒的小兔
愤怒的小兔
回复 @markYun : 第一行和第二行不是重复的哦,是分别安装的,貌似是4.x开始拆分的。
愤怒的小兔
愤怒的小兔
回复 @markYun :是大写啊,卸载掉原来安装的,添加好环境变量,重新按照上面的步骤安装呢。确认你有文件修改权限啊
下一页
1
愤怒的小兔
愤怒的小兔
你不是4.9吗,4.9不安装express-generator能玩?我觉得你现在应该找本书,别管最新是什么版本,就按照教程上的版本来,先把基础的搞好了,简单项目上手了再搞高级版本的。到时出了故障你也有基础知识打底,否则搞来搞去都是基础问题,没有用的。还有系统可以弄个虚拟机使用Linux,windows玩nodejs真不推荐了。附上朴灵大大的教程:http://www.ituring.com.cn/book/1290,另外还有本实践教程:http://www.ituring.com.cn/book/1061。电子版的书比较便宜。
0
愤怒的小兔
愤怒的小兔
貌似是安装成功了,但是没有“-v”这个选项,你可以试试“-V” 或者其它的命令试试。说句可能不爱听的啊,玩nodejs还是选linux吧,有时在windows下会出一些莫名其妙的问题。
markYun
markYun
回复 @大熊兔先生 : 4.9的
markYun
markYun
最后我又安装了一次,提示是OK的。 、、、 └── constantinople@2.0.1 (uglify-js@2.4.15) npm info ok Administrator@MARKYUN /d/nodejs $ express destination is not empty, continue? 。
愤怒的小兔
愤怒的小兔
回复 @markYun : 你安装的express是3.x还是4.x的呢?
markYun
markYun
没有, node 和npm 安装成功了,express没安装成功,但提示是安装成功了, 然后我启动应用:Cannot find module 'express-scaffold' 报错。
愤怒的小兔
愤怒的小兔
是否解决了呢?
返回顶部
顶部