3
回答
请问如何解决dlog4j的问题?
利用AWS快速构建适用于生产的无服务器应用程序,免费试用12个月>>>   
我在自己的vps上安装了jdk+tomcat,见此: http://luckypoem.co.cc:8080/old-content/
不过我上传dlog4j.war到webapps/ROOT/,
解压后访问 http://luckypoem.co.cc:8080,出现错误。请问如何解决?

是否我的hibernate.cfg.xml没改对?它的内容如下:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE hibernate-configuration PUBLIC
    "-//Hibernate/Hibernate Configuration DTD 3.0//EN"
    " http://hibernate.sourceforge.net/hibernate-configuration-3.0.dtd">

<hibernate-configuration>
   
    <session-factory>
       
        <!-- ********** database relative settings ********** -->
       
        <!-- MySQL 3/4/5 -->
        <!-- ?useUnicode=true&amp;characterEncoding=GBK -->
        <!--
        <property name="dialect">org.hibernate.dialect.MySQLDialect</property>
        <property name="dscp.driverClassName">com.mysql.jdbc.Driver</property>
        <property name="dscp.url">jdbc:mysql://localhost:3306/我的数据库名</property>               
        <property name="dscp.username">我的用户名</property>
        <property name="dscp.password">我的密码</property>
        -->
       
        <!-- ********** database independence settings ********** -->
        <property name="connection.provider_class">com.liusoft.dlog4j.db.DataSourceConnectionProvider</property>
       
        <!-- Connection Pool using DBCP -->       
        <property name="dscp.datasource">org.apache.commons.dbcp.BasicDataSource</property>
        <property name="dscp.initialSize">1</property>
        <property name="dscp.maxActive">200</property>
        <property name="dscp.maxIdle">10</property>
        <property name="dscp.maxWait">2000</property>
        <property name="dscp.defaultAutoCommit">false</property>
        <property name="dscp.poolPreparedStatements">true</property>
        <property name="dscp.maxOpenPreparedStatements">1000</property>
        <!-- TRANSACTION_READ_UNCOMMITTED -->
        <!--
        <property name="dscp.defaultTransactionIsolation">1</property>       
        -->
       
        <!-- ********** global settings ********** -->
        <property name="show_sql">false</property>
        <property name="jdbc.batch_size">100</property>
        <property name="use_outer_join">false</property>
        <property name="cache.use_query_cache">true</property>
        <property name="default_batch_fetch_size">20</property>
        <property name="jdbc.use_scrollable_resultset">true</property>
        <property name="jdbc.use_reflection_optimizer">true</property>
       
        <!-- ********** beans mapping ********** -->
       
        #<mapping resource="access/dlog.hbm.xml"/>
        <mapping resource="access/core.hbm.xml"/>
        <mapping resource="access/diary.hbm.xml"/>   
        <mapping resource="access/photo.hbm.xml"/>
        <mapping resource="access/music.hbm.xml"/>       
        <mapping resource="access/bbs.hbm.xml"/>
        <mapping resource="access/query.hbm.xml"/>
        <mapping resource="access/other.hbm.xml"/>
       
        <!--
        <mapping resource="com/liusoft/dlog4j/hbm/dlog.hbm.xml"/>
        <mapping resource="com/liusoft/dlog4j/hbm/core.hbm.xml"/>
        <mapping resource="com/liusoft/dlog4j/hbm/diary.hbm.xml"/>   
        <mapping resource="com/liusoft/dlog4j/hbm/photo.hbm.xml"/>
        <mapping resource="com/liusoft/dlog4j/hbm/music.hbm.xml"/>       
        <mapping resource="com/liusoft/dlog4j/hbm/bbs.hbm.xml"/>
        <mapping resource="com/liusoft/dlog4j/hbm/query.hbm.xml"/>
        <mapping resource="com/liusoft/dlog4j/hbm/other.hbm.xml"/>
        -->
       
    </session-factory>
   
</hibernate-configuration> 
谢谢答复。
举报
yuming
发帖于6年前 3回/432阅
顶部