centos6.3下安装了fcitx只能在emacs下调用成功

garbageaa 发布于 2013/04/14 11:06
阅读 833
收藏 0
在centos6.3下安装了fcitx-4.2.1-6.4.i686,可是只能在emacs下调用成功(fcitx配置文件默认用emacs打开,这有影响??)。要在能输入的地方调用fcitx,哪些地方设置不对啊?

下面是对fcitx进行设置的截图及fcitx本身的配置:

[Program]
# Seconds sleep before fcitx really start
DelayStart=0
# Share State Among Window
# Available Value:
# No All PerProgram change No to All by dy
ShareStateAmongWindow=All
# Default Input Method State
# Available Value:
# Close Inactive Active
#DefaultInputMethodState=Close
DefaultInputMethodState=Close

# It's the first time Fcitx Start.
# Available Value:
# True False
FirstRun=False
# Use first input method as inactive state
# Available Value:
# True False
FirstAsInactive=False

[Output]
# Type half width Punc After a Number
# Available Value:
# True False
HalfPuncAfterNumber=True
# Action after press enter
# Available Value:
# Nothing Clean Commit
EnterAction=Commit
# Disable Paging in Remind Mode
# Available Value:
# True False
RemindModeDisablePaging=True
# Send typed raw text if Switch to inactive Mode
# Available Value:
# True False
SendTextWhenSwitchEng=False
# Candidate Word Number
CandidateWordNumber=5
# Give the tips of Phrase
# Available Value:
# True False
PhraseTips=True

[Appearance]
# Show Input Window After Trigger Input Mode
# Available Value:
# True False
ShowInputWindowAfterTriggering=True
# Show Point After Index
# Available Value:
# True False
ShowPointAfterIndex=True
# Show Input Speed
# Available Value:
# True False
ShowInputSpeed=True
# Show Version
# Available Value:
# True False
ShowVersion=True
# Do not show input window if there is only preedit string
# Available Value:
# True False
HideInputWindowWhenOnlyPreeditString=False
# Do not show input window if there is one one candidate (Hide when only preedit string must be selected)
# Available Value:
# True False
HideInputWindowWhenOnlyOneCandidate=False

[Hotkey]
# Hot key of Triggering Input Method
TriggerKey=CTRL_SPACE
# Enable Left Ctrl + Left Shift to Switch Between Input Method
# Available Value:
# True False
IMSwitchKey=True
# Hotkey of Switching Active and Inactive Mode
# Available Value:
# R_CTRL R_SHIFT L_SHIFT L_CTRL ALT_L_SHIFT ALT_R_SHIFT Disabled
SwitchKey=L_CTRL
# Double click Switch Key to Change Mode
# Available Value:
# True False
DoubleSwitchKey=False
# Interval of Two Key Input
TimeInterval=250
# Hotkey of Switching Virtual Keyboard
VKSwitchKey=CTRL_ALT_B
# Hotkey of Switching Remind Mode
RemindSwitchKey=
# Hotkey of Switching Full Width Character Mode
FullWidthSwitchKey=SHIFT_SPACE
# Hotkey of Switch Full Width Punc Mode
PuncSwitchKey=ALT_SPACE
# Hotkey of Going Prev Page
PrevPageKey=-
# Hotkey of Going Next Page
NextPageKey==
# Hotkey to Choose Second and Third Candidate Word
SecondThirdCandWordKey=SHIFT
# Hotkey of Saving All Config and Input History
SaveAllKey=CTRL_ALT_S
# Hotkey of Switch Embeded Preedit
SwitchPreedit=CTRL_ALT_P

加载中
0
红薯
红薯
不会,帮顶
garbageaa
garbageaa
最后还是换成ibus解决了输入法
0
chenwenli
chenwenli
换ibus试试
chenwenli
chenwenli
@A_A ibus也有毛病啊~是因为x的原因,还有是快键键冲突的原因,建议细查
garbageaa
garbageaa
最后还是用ibus解决了输入法。thanks你的建议,但没解决为什么只有在emacs中可以调用fcitx,所以不能把你的回答设为最佳。
0
Soge
Soge

参考

https://wiki.archlinux.org/index.php/Fcitx_(简体中文)

桌面的话配置是.xprofile

最后需要添加个fcitx &启动吗

太久没用,忘了

garbageaa
garbageaa
又折腾了一会,还是只有在emacs中才可以使用。centos6.3最小安装后装的gnome桌面
0
Y
YuYichao

1, 你的版本已过时 (最新版是4.2.7)

2, 输入法的配置完全不对, 需要设置的只有很少几个环境变量 具体参见 fcitx 的 wiki https://fcitx-im.org/wiki/Configure_(Other) 不要参考任何网上搜索到的配置"教程", 几乎没有一个是对的

3, 估计你就是环境变量设错了, 不过你的版本过于过时, 我也不是很清楚有没有gtk的immodule, 如果需要的话运行下这个脚本铁输出 https://github.com/fcitx/fcitx/blob/master/data/script/fcitx-diagnose.sh

4, fcitx的问题请到 fcitx 的 googlegroup 上面问, 在这种地方提问 fcitx 的问题不要指望得到靠谱的回答, 我们不可能跑遍每个论坛回答fcitx的问题 https://fcitx-im.org/wiki/How_to_contact_with_Fcitx_team

garbageaa
garbageaa
很好的建议,thanks。最近事情比较多,fcitx暂时放一放。迟早会让它顺从的
返回顶部
顶部