git的使用问题,"您当前分支的最新提交落后于其对应的远程分支"

逝水fox 发布于 2013/09/27 09:11
阅读 2K+
收藏 0
Git

因为以前用git都只是本地提交,没有做服务器,不知道这个问题是不是自己的操作问题,请各位帮忙看下。

从服务器pull了代码出来,修改之后使用--amend来追加到最后一次提交里面

git commit --amend .
然后这个时候push代码会提示:更新被拒绝,因为您当前分支的最新提交落后于其对应的远程分支。

不知道这个是不是我操作的问题,不要--amend就不会出问题。

加载中
0
逝水fox
逝水fox
查了下,好像确实是这个操作有问题
0
douglarek
douglarek
git push -f
逝水fox
逝水fox
请问 这个是指的是强制push,不检查版本吗?
0
冷血
冷血
已经push到服务器的提交历史最好不要再修改。你这里不能使用 amend提交。
返回顶部
顶部