PHP win764位下 curl无法开启

jacky-zhuo 发布于 2012/11/21 17:07
阅读 5K+
收藏 0

PHP Startup:Unable to load dynamic library

'D:/wamp/bin/php/php5.3.13/ext/php_curl.dll' - 应用程序无法启动, 因为应用程序的并行配置不正确. 有关详细信息, 请参阅应用程序事件日志, 或使用命令行 sxstrace.exe 工具.

正确的PHP配置php_curl模块, 启动php报这个错误, 不知道怎么解决, 希望有人可以帮帮解决

环境配置win7(64bit) + Apahce2.2.22 + PHP5.3.13 + MySql5.5.24

加载中
0
南湖船老大
南湖船老大

引用来自“ouyangshiqiang”的答案

Apache配置httpd.conf里面增加,自己改成对应的php目录
PhpIniDir "D:/web/php/"
LoadFile "D:/web/php/libmysql.dll"
LoadFile "D:/web/php/libeay32.dll"
LoadFile "D:/web/php/ssleay32.dll"
这。。明显没有用啊,这是兼容性问题,不是配置问题。只能下64位的编译版本了
0
薯片
薯片
Apache配置httpd.conf里面增加,自己改成对应的php目录
PhpIniDir "D:/web/php/"
LoadFile "D:/web/php/libmysql.dll"
LoadFile "D:/web/php/libeay32.dll"
LoadFile "D:/web/php/ssleay32.dll"
0
jacky-zhuo
jacky-zhuo

引用来自“ouyangshiqiang”的答案

Apache配置httpd.conf里面增加,自己改成对应的php目录
PhpIniDir "D:/web/php/"
LoadFile "D:/web/php/libmysql.dll"
LoadFile "D:/web/php/libeay32.dll"
LoadFile "D:/web/php/ssleay32.dll"
还是报同样的错误
0
首席xx师
首席xx师

http://www.anindya.com/php-5-4-0-x64-64-bit-for-windows/

php5.4.0   win7 64位 下可以用

首席xx师
首席xx师
回复 @Mr.zHuo : 国外很多网站有win 64位下各版本的php
jacky-zhuo
jacky-zhuo
要到5.4.0才能用吗? 其他版本的都不可以?
0
i
instooo
http://download.csdn.net/detail/instooo/9485870 下载替换掉PHP目录下的即可,测试成功ssleay32.dll
返回顶部
顶部