phalcon在ubuntu14.04编译安装

dreamhack 发布于 2014/04/22 15:46
阅读 1K+
收藏 0

哪位安装成功了?求指教,我特么快被气死了。。。


加载中
1
吴小华
吴小华


sudo vim /etc/php5/mods-available/phalco.ini 入写编译好的模块 如:extension=phalco.so

sudo ln -s /etc/php5/mods-available/phalco.ini /etc/php5/apache2/conf.d/phalco.ini 

重新启动

sudo reboot

再查看phpinfo  配置Additional .ini files parsed是否有phalco.ini


dreamhack
dreamhack
回复 @吴小华 : 嗯,软链接应该是:sudo ln -s /etc/php5/mods-available/phalcon.ini /etc/php5/apache2/conf.d/phalcon.ini 吧,现在都有了,下面货站列表还是没有,,,总是各种神奇的问题。难道是扩展的.so文件问题?应该不会,对了,安装的64bit的os
吴小华
吴小华
php.ini里是否取消extension=phalco.so ,软链接要权限,要用绝对值链接
dreamhack
dreamhack
Additional .ini files parsed有phalco.ini ,但下面扩展还是没有,软链接创建失败。。我看看咋回事,是root啊
0
嘟嘟的米
嘟嘟的米

改了ini配置文件后重启了吗?

嘟嘟的米
嘟嘟的米
回复 @dreamhack : 或者你把整个PHP.INI配置贴出来看下
嘟嘟的米
嘟嘟的米
回复 @dreamhack : 是不是你PHP装了个多个版本?
dreamhack
dreamhack
哎,,何止Apache啊,系统都重启N次了,我就想不通哪里的问题,是不php.ini不是那个?还是路径问题?
0
吴小华
吴小华

/etc/php5/mods-available/phalco.ini  软链接  /etc/php5/apache2/conf.d/phalco.ini 
如果/etc/php5/mods-available/phalco.ini 不存在 需要先新建一个phalco.ini 并写入extension=phalco.so 重启就可以的,我也是搞UBUNTU14.04 研究出来的,ubuntu默然安装PHP5.5.9 配置文件php.ini无需修改哦,切忌。

0
吴小华
吴小华

所有新编译模块都是按上面的操作就可以的。比如安装mongodb redis都是这样做的没有问题

0
吴小华
吴小华

我安装mongodb就是这样安装的,你看是php版本问题?ubuntu14.04apt-get安装是5.5.9.1

0
dreamhack
dreamhack

@吴小华 ,连物理机也重启下,现在好了,谢谢你了兄弟!

返回顶部
顶部