为什么我升级jfinal1.9之后 打开jsp页面 会出现错误

消逝 发布于 2014/11/08 14:43
阅读 621
收藏 0

刚刚把 jfinal 架包升级到了1.9 可是我打开原来可以成功运行(在1.8上可以成功打开jsp页面不会报错)的页面时会报错

com.jfinal.render.RenderException: org.apache.jasper.JasperException: javax.el.PropertyNotFoundException: The class 'com.model.Code' does not have the property 'unitid'.
at com.jfinal.render.JspRender.render(JspRender.java:69)
at com.jfinal.core.ActionHandler.handle(ActionHandler.java:92)
at com.jfinal.ext.handler.ContextPathHandler.handle(ContextPathHandler.java:47)

后来我看了更新日志 把 JspRender.isSupportActiveRecord 中的值改为 true 就可以运行了

那么我想问一下 增强jsp之下的jstl的EL输出,添加ModelRecordElResolver,JspRender.isSupportActiveRecord默认值改为false,默认使用EL增强 

这是什么意思啊!



加载中
0
糊搞
检查你的JSTL的Jar包
返回顶部
顶部