ubuntu12.04安装zhcon,出现的问题

爱书生 发布于 2012/08/24 14:38
阅读 2K+
收藏 0

这几天一直在啄磨安装zhcon,偏偏安装过程总是出现一些问题

最开始,在uBUNTU软件中心安装zhcon,很简单,提示安装成功,得在文档模式启动zhcon!进tty1  #zhcon 失败,#zhcon --utf8 --drv=vga   提示输入utf8不止一次!搜教程,中间的先不说,先说最近的问题

首先将源代码解开到一个临时目录:

tar zxf zhcon-0.2.5.tar.gz -C /tmp
cd /tmp/zhcon-0.2.5

然后运行configure脚本检查系统编译环境,创建Makefile

./configure

这是出现了问题

checking how to run the C++ preprocessor... /lib/cpp
configure: error: C++ preprocessor "/lib/cpp" fails sanity check
不过已经解决掉
接着make
问题出现了
make  all-recursive
make[1]: 正在进入目录 `/tmp/zhcon-0.2.5'
Making all in src
make[2]: 正在进入目录 `/tmp/zhcon-0.2.5/src'
Making all in display
make[3]: 正在进入目录 `/tmp/zhcon-0.2.5/src/display'
if g++ -DHAVE_CONFIG_H -I. -I. -I../.. -I../../src    -funsigned-char -O2 -march=i686 -DNDEBUG -Wall -MT fblinear4.o -MD -MP -MF ".deps/fblinear4.Tpo" -c -o fblinear4.o fblinear4.cpp; \
then mv -f ".deps/fblinear4.Tpo" ".deps/fblinear4.Po"; else rm -f ".deps/fblinear4.Tpo"; exit 1; fi
fblinear4.cpp: 在成员函数‘virtual void FBLinear4::FillRect(int, int, int, int, int)’中:
fblinear4.cpp:75:29: 错误: ‘memset’在此作用域中尚未声明
make[3]: *** [fblinear4.o] 错误 1
make[3]:正在离开目录 `/tmp/zhcon-0.2.5/src/display'
make[2]: *** [all-recursive] 错误 1
make[2]:正在离开目录 `/tmp/zhcon-0.2.5/src'
make[1]: *** [all-recursive] 错误 1
make[1]:正在离开目录 `/tmp/zhcon-0.2.5'
make: *** [all] 错误 2


至今还没有找到解决问题的办法,求各位大大帮帮忙,在文本模式下不能显示中文很恼人的,谢谢各位啦!

加载中
返回顶部
顶部