包依赖的问题

huxuanhui 发布于 2010/05/16 00:17
阅读 162
收藏 0

[root@rhel6beta Packages]# rpm -ivh libproxy-0.3.0-1.el6.i686.rpm
warning: libproxy-0.3.0-1.el6.i686.rpm: Header V3 RSA/SHA256 Signature, key ID f21541eb: NOKEY
error: Failed dependencies:
        libproxy-bin = 0.3.0-1.el6 is needed by libproxy-0.3.0-1.el6.i686
        libproxy-python = 0.3.0-1.el6 is needed by libproxy-0.3.0-1.el6.i686
[root@rhel6beta Packages]# rpm -ivh libproxy-bin-0.3.0-1.el6.i686.rpm
warning: libproxy-bin-0.3.0-1.el6.i686.rpm: Header V3 RSA/SHA256 Signature, key ID f21541eb: NOKEY
error: Failed dependencies:
        libproxy = 0.3.0-1.el6 is needed by libproxy-bin-0.3.0-1.el6.i686
        libproxy.so.0 is needed by libproxy-bin-0.3.0-1.el6.i686
[root@rhel6beta Packages]# rpm -ivh libproxy-python-0.3.0-1.el6.i686.rpm
warning: libproxy-python-0.3.0-1.el6.i686.rpm: Header V3 RSA/SHA256 Signature, key ID f21541eb: NOKEY
error: Failed dependencies:
        libproxy = 0.3.0-1.el6 is needed by libproxy-python-0.3.0-1.el6.i686

 

貌似死循环了???

加载中
0
huxuanhui
huxuanhui

问题解决啦

分享下解决方案

灰常简单 就是 把三个包放在一起安装

rpm -ivh libproxy-0.3.0-1.el6.i686.rpm libproxy-bin-0.3.0-1.el6.i686.rpm libproxy-python-0.3.0-1.el6.i686.rpm

就okay了

哈哈

返回顶部
顶部