有办法在32位pc机器上centos系统里使用GOlang1.6么?

阿采 发布于 2016/03/07 01:11
阅读 330
收藏 0

make 一个包提示如下错误:

Extra ldflags: 
go build: -race and -msan are only supported on linux/amd64, freebsd/amd64, darwin/amd64 and windows/amd64

有什么办法能规避这错误么?  //需要使用GOlang1.6的版本

下面是系统环境:

[root@localhost lantern]# uname -a
Linux localhost.localdomain 2.6.32-573.18.1.el6.i686 #1 SMP Tue Feb 9 19:51:22 UTC 2016 i686 i686 i386 GNU/Linux

[root@localhost lantern]# head -n 1 /etc/issue
CentOS release 6.7 (Final)



加载中
0
Adairs
Adairs
你下载的是64位的安装包,你看看有没有32位的安装包
阿采
阿采
回复 @Adairs : 我就是下的这个版本,哎,不行
阿采
阿采
golang官网上不去,我是在http://www.golangtc.com/download下载的go1.6.linux-386.tar.gz,看上去似乎没有更低的了
Adairs
Adairs
http://www.golangtc.com/download选择go1.6.linux-386.tar.gz
返回顶部
顶部