linux安装svn

steemit 发布于 2013/11/16 16:24
阅读 371
收藏 0

在linux已经安装了subversion,在eclipse安装svn插件,启动eclipse报错:

incompatible javahl library loaded. 1.7.x or later required.

于是在线安装了高版本的JavaHL:

sudo rpm -i subversion-javahl-1.8.4-2.x86_64.rpm,成功之后再次重启eclipse,不兼容的javaHL错误消失,但是出现如下错误:

JVM terminated. Exit code=127


启动eclipse的终端报错如下:

/usr/lib64/libsvnjavahl-1.so.0.0.0: undefined symbol: svn_utf_initialize2

看错误肯定和上面按转的JavaHL有关系,但是不知道如何解决???

路过的帮忙看看,谢谢!

加载中
0
POintMELOve
POintMELOve

很难看出错在哪里,可能版本不兼容吧。

如果是在eclipse中使用SVN的话,使用eclipse安装完svn插件后,重启后eclipse会提示安装svn provider。这时选安装JavaHL不会有问题。

返回顶部
顶部