关于3.6.10升级的问题

宋五哥 发布于 2017/09/13 16:14
阅读 284
收藏 0

@青苗 你好,想跟你请教个问题:

由3.6.10升级到3.6.11或12或13都会报错:

java.lang.ArrayIndexOutOfBoundsException: 1
    at com.baomidou.kisso.service.KissoServiceSupport.getJsonToken(KissoServiceSupport.java:217) ~[kisso-3.6.11.jar:?]
    at com.baomidou.kisso.service.KissoServiceSupport.getToken(KissoServiceSupport.java:178) ~[kisso-3.6.11.jar:?]


。。。。。。

是什么原因呢?

需要改sso.properties文件吗?

另外如果想升级到3.7.0怎么升级呢,谢谢大神指导

加载中
0
宋五哥
宋五哥

另外有这几个错误

九月 13, 2017 4:22:34 下午 com.baomidou.kisso.service.KissoServiceSupport generateCookie
严重: generateCookie is exception!java.lang.ClassCastException: java.lang.reflect.Method cannot be cast to java.lang.Class
九月 13, 2017 4:22:34 下午 com.baomidou.kisso.common.encrypt.SSOSymmetrical decrypt
严重: Encrypt setKey is exception.
九月 13, 2017 4:22:34 下午 com.baomidou.kisso.service.KissoServiceSupport getJsonToken
严重: jsonToken decrypt error, may be fake login. IP = 10.16.6.231
九月 13, 2017 4:22:34 下午 com.baomidou.kisso.service.KissoServiceSupport getJsonToken
严重: SSOHelper getToken, find Browser is illegal.

0
宋五哥
宋五哥

还有,用3.6.10的时候,报错为

com.baomidou.kisso.service.AbstractKissoService ok
严重: kisso AES decrypt error.
com.baomidou.kisso.exception.KissoException: javax.crypto.BadPaddingException: Given final block not properly padded

返回顶部
顶部