Kali Linux2019.2 使用 fcitx 安装搜狗输入法失败,报 fcitx-frontend-gtk2安装失败,GLib version too old

山哥 发布于 08/31 13:55
阅读 181
收藏 0

大家好,

今天使用虚拟机(Mac Parallels)安装了 Kali Linux 2019.2 最新版,然后尝试安装 搜狗输入法,老是报错:

Cannot load module /usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules/im-fcitx.so: GModule (/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules/im-fcitx.so) initialization check failed: GLib version too old (micro mismatch) /usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules/im-fcitx.so does not export GTK+ IM module API: GModule (/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/immodules/im-fcitx.so) initialization check failed: GLib version too old (micro mismatch)

这个 fcitx 安装不成功,提示 GLib version too old,但是 Kali 2019.2 中的 glibc 是 2.28 已经很新了,折腾2天了,都没有搞定中文输入法的安装。

请大家帮忙看看如何解决?

以下是问题补充:

@山哥:【已解决】使用 apt-get install libglib2.0-dev  来升级GLib包。 (09/02 15:49)
加载中
0
山哥
山哥

【已解决】使用 apt-get install libglib2.0-dev  来升级GLib包。

返回顶部
顶部