@红薯 Git本地和Git@OSC同步出现问题.

R-Lu 发布于 2013/05/23 14:18
阅读 4K+
收藏 1
Git


@红薯 我这个项目是以前学习的项目,文件有点多,大概有700+吧,所以传起来有点慢,但是这个貌似远程无响应呀.

不知道怎么回事.

加载中
0
王振威
王振威

你可以试试这么做,

默认Git设置http post的缓存为1M

解决方法:
增加http post缓存, 如果使用git命令,设置参数命令如下:
#增加为 500MB
git config http.postBuffer 524288000

如果使用的是Eclipse Git插件,则需要在 Window -> Preferences 中找到 Team -> Git -> Configuration 配置界面,在System Settings Tab页中 点击 “Add Entry…” 按钮来添加一个配置项:

key为: http.postBuffer
value为:524288000

如果还不行,可以尝试升级egit插件。

0
R-Lu
R-Lu

引用来自“王振威”的答案

你可以试试这么做,

默认Git设置http post的缓存为1M

解决方法:
增加http post缓存, 如果使用git命令,设置参数命令如下:
#增加为 500MB
git config http.postBuffer 524288000

如果使用的是Eclipse Git插件,则需要在 Window -> Preferences 中找到 Team -> Git -> Configuration 配置界面,在System Settings Tab页中 点击 “Add Entry…” 按钮来添加一个配置项:

key为: http.postBuffer
value为:524288000

如果还不行,可以尝试升级egit插件。

这样提交倒是快了,不过,有点问题的是,它这个错误. 应该还是Git@OSC那边接受不了这么多数据吧.

R-Lu
R-Lu
怎么生存公钥...
tsl0922
tsl0922
实在在不行,用eclipse生成一个公钥添加到http://git.oschina.net/keys,使用SSH方式push吧,速度会比HTTP快很多。
0
R-Lu
R-Lu
可能Git@OSC刚刚起步,空间准备的不足吧.不过这个真的很好了.
返回顶部
顶部