(入手PHPStorm 6.0同学注意)中文显示♢♢♢的问题解决方法

神勇无敌小密探 发布于 2013/04/01 14:13
阅读 14K+
收藏 8

各位刚入手PHPStorm6的同学不知道有木有遇到和我一样的问题,具体表现如下:

本来用5.04的破解版的时候中文都完全没问题的但是到了6.0居然倒退了这点真是让人郁闷,网上也没解决方案,但是今天我在研究字体的时候意外发现~~

如上图所示,在首选项中多了一个Theme相关的设置项,如果你没有设置过Theme,可能不会遇到这个问题,但是如果你像我一样心里充满阳光却喜欢阴暗的色调并设置了主题为Darcula(~其他主题未测试~),那么就可能遇到中文乱码的问题。解决方法就是把

Override default fonts by

这一项勾上并在下面选择选择一个中文字体,然后重启IDE,中文的地方就回来啦~~

加载中
0
曾建凯
曾建凯
你应该使用正版软件!
0
Narky
Narky

这不是什么正版不正版的问题

这是java软件字体设置的通病

0
ClownFish
ClownFish
谢谢楼主,困扰我的问题解决了
0
奋斗哥
奋斗哥
没碰到这个问题
0
java9
java9
这已经不是什么问题了
0
酒肉穿肠过
酒肉穿肠过
帮我解决了,谢谢楼主!
0
sjclijie
sjclijie
PHPstorm 如何像zendstudio那样一次删除一个tab(四个空格)啊?
sjclijie
sjclijie
回复 @mfy : tks~~~
m
mfy
Project Settings/Code Style/PHP/Tabs and Indents Use tab character: yes Smart tabs: yes Tab size: 4 Indent: 4 Continuation indent: 4
神勇无敌小密探
神勇无敌小密探
按shift+tab就可以了~~ @sjclijie
神勇无敌小密探
神勇无敌小密探
按shift+tab就可以了~~
0
黑色技术
黑色技术
= = 我记得以前只设置字体就不乱码,现在要设置主题,麻烦.
0
黑色技术
黑色技术
= = 对了,我记得以前有js写代码有个跟html,速写一样的,只写部分+快捷键就可以出来,还可以自定义的,导入js模板的,不过那个文件不知道扔哪了,还不知道哪里设置了- -,不知道你懂不懂呢?
黑色技术
黑色技术
好像没反应,记得以前是可以的,不知道是版本问题还是什么。我电脑用的是7.0
神勇无敌小密探
神勇无敌小密探
是不是live template?你可以在配置项里搜索一下~~就是设置好代码模板~~这个所有语言都可以用~~
0
黑色技术
黑色技术

6.0版本的我有汉化包。- -需要的联系我。

返回顶部
顶部