ubuntu14.04 wifi频繁掉线

coolcao 发布于 2015/05/04 22:55
阅读 11K+
收藏 0

各位使用ubuntu的小伙伴们,你们的无线稳定吗,我使用的是ubuntu14.04,电脑是e530c,无线频繁掉线,基本到了无法忍受的程度。

使用的内核3.14 , 3.15,3.15,4.0,4.1,都会掉线。

我上网查,有的说是内核对我这个网卡的兼容性不好,我把内核换了个遍,从3.14,3.15,3.16,4.0,4.1的内核都用过,都有掉线。有说是我安装的网卡驱动有问题,我从github上下载了一个编译好的相应网卡的驱动,还是不行,还是掉线。我本想从网卡的官网下载驱动安装,无奈官网的linux驱动只有源码,我下载下来编译不了,不知道咋回事。

内核自带的网卡驱动,从网上下载的第三方驱动,都会掉线,搞得我真不知道咋好了。对ubuntu失去信心了呀,大家有没有类似的经历,分享一下啊


好吧,在我打完这些字的这两分钟内,又掉线了。。。

加载中
0
南湖船老大
南湖船老大
Windows才是一个正常电脑用户的选择
0
南湖船老大
南湖船老大
你是自己折腾自己,有意思么?就算你解决了,甚至搞懂原理,有什么用?收获了什么?值得吗?开心吗?有必要吗?这本来就是正常操作系统不会有的问题,你付出的一切都是浪费时间,没任何价值。
0
eechen
eechen
我的Acer本用的是Qualcomm Atheros AR9485 Wireless Network Adapter,驱动用的是内核自带的ath9k,很稳定,并且支持建立AP热点供手头的Android手机上网:
http://my.oschina.net/eechen/blog/227230
sudo lshw 查看你的硬件信息,里面有你的无线网卡型号,执行 lspci -vv 可以看到你的无线网卡当前使用的驱动。
c
coolcao
如果这样的话,没办法了。
eechen
eechen
回复 @coolcao : 这既不是Ubuntu的问题,也不是Kernel的问题,而是Realtek的Linux驱动问题. Intel,Atheros,Broadcom,Realtek这四家中,估计就湾湾的瑞昱Realtek对Linux支持不好了. 还是建议买个USB无线网卡吧,我的友讯DWL-G122,插上就能用.
c
coolcao
我的网卡是RTL8188CE,网上搜的各种方法貌似不管用
0
eechen
eechen
Thinkpad用的应该是Intel的无线网卡,Intel的无线网卡驱动也是开源的:
https://01.org/zh/intel-wireless-linux
http://git.kernel.org/cgit/linux/kernel/git/iwlwifi/iwlwifi-fixes.git
/lib/modules/`uname -r`/kernel/drivers/net/wireless/iwlwifi/iwlwifi.ko
0
szf
szf

3.13 3.16才是ubt14.04官方仓库的内核版本,不知道你的3.14,3.15从哪来的。。。

另外,dmesg内核消息会有相关网络接口提示,iwevent会有无线网卡状态变化提示,无论哪个提示,对你的掉线问题都有帮助。

如果对linux不熟悉,就不要玩编译内核了,按步就班地make完,真的什么都不懂的。应该按照发行版设计理念,把包管理系统搞熟悉(比如rpm/yum,dpkg/apt),然后在这个框架内搞定自己的问题。

就我来说,用过NN台电脑上的Linux,有服务器有桌面,有台机有笔记本,无论是有线无线,都不存在网络不稳定的问题,只编译过有限次网卡驱动源码,最容易遇到硬件驱动还要装固件包。。。

希望这些经验有帮助。

szf
szf
你这么没头绪都编译了最新内核版本!我回复里提到了内核消息和无线事件工具了,先试试吧。
szf
szf
但是各种兼容性,稳定性测试呢~你说的这个是官方提供的尝鲜性质包
c
coolcao
我不是搞linux内核编程的,做web开发的,所以linux底层的一些东西确实搞不了。我的这个问题不知道是驱动的问题,还是内核的问题,或者是哪里设置的不对了,没头绪
eechen
eechen
回复 @szf : kernel.ubuntu.com 这个域显然只有Canonical能够提交。
szf
szf
回复 @eechen : 我认为ppa只能算准官方吧
下一页
0
_冬_至_
_冬_至_
我也遇到了同样的问题,将/etc/ppp/options 文件中的 lcp-echo-failure 4 改为 lcp-echo-failure 40
0
Stven_King
Stven_King

引用来自“_冬_至_”的评论

我也遇到了同样的问题,将/etc/ppp/options 文件中的 lcp-echo-failure 4 改为 lcp-echo-failure 40
解决了目前的问题
返回顶部
顶部