linux下yum安装软件提示找不到jdk

实迷途其未远觉今是而昨非 发布于 2012/09/29 20:35
阅读 2K+
收藏 0
JDK

【华为云1024程序员节·向云而生】预约直播 抽14件华为电子产品礼包!>>>

使用yum更新软件时,提示没有jre环境

jre >= 1.5.0 is needed by libreoffice-ure-1:3.4.5.2-16.1.el6_3.x86_64

我把原来的open jdk卸载了,换成了oracle 的jdk 1.7

/etc/profile里面的配置也都配了,见最后

eclipse等java ide都是可以用的

java -version也能看到jdk版本

 

 

 

#set java environment

JAVA_HOME=/usr/java/jdk1.7.0_07

JRE_HOME=$JAVA_HOME/jre

PATH=$JAVA_HOME/bin:$PATH:/usr/idea-IU-117.798/bin/:/usr/soft/gogent/local/

CLASSPATH=.:$JAVA_HOME/lib/dt.jar:$JAVA_HOME/lib/tools.jar

export JAVA_HOME

export JRE_HOME

export PATH

export CLASSPATH


加载中
0
逝水fox
逝水fox
那就再通过yum装个openjdk,这个是libreoffice依赖的没办法,你设置好环境变量了之后,命令行什么的会用你自己装的1.7,不会有冲突的
0
A阿福A
A阿福A
为啥要用1.7?
A阿福A
A阿福A
@狼牙化石 1.7现在还普及不了啊,估计还得一段时间,现在用6就行啊,主流
实迷途其未远觉今是而昨非
实迷途其未远觉今是而昨非
换了open jdk,1.7有什么问题吗?
返回顶部
顶部