IAR6.4编译6.2以前版本的问题

长平狐 发布于 2013/03/19 18:19
阅读 286
收藏 0

转自:http://blog.csdn.net/hitxiaya/article/details/8017641

 

IAR6.2以后的版本编译IAR6.2以前的版本会出现如下错误:

Error[Pe147]: declaration is incompatible with "__nounwind __interwork __softfp unsigned long __REV16(unsigned long)" (declared at line 177 of "C:\ E:\STM32资料\源码\36 以太网STM32F107_ETH_LCD(神舟IV号)TFTP文件传输\Libraries\CMSIS\Core\CM3\core_cm3.h 710

错误的原因是因为新版本CMSIS的intrinsics.h等文件与之前的版本不兼容。

解决办法:

1: Project options > General Options > Library
Configuration 里选择 USE CMSIS ;


2:在Project>Options>C/C++Compiler>Preprocessor里删除所有的 CMSIS header files ,
“$PROJ_DIR$\..\..\..\Libraries\CMSIS\CM3\CoreSupport” 。
再次编译,通过。。。。。


希望对遇到同样问题的朋友提供帮助,参考文件:TN0803 Techinical note
How to use EWARM 6.2X with projects built with EWARM 6.1 and previous versions


原文链接:http://blog.csdn.net/flydream0/article/details/8229001
加载中
返回顶部
顶部