Unable to find required classes (javax.activation.DataHandler and javax.mail.internet.MimeMultipart)

长平狐 发布于 2012/12/10 17:18
阅读 4K+
收藏 0

在接触WebService时值得收藏的一篇文章:

在调试Axis1.4访问WebService服务时,出现以下错误:

Unable to find required classes (javax.activation.DataHandler and javax.mail.internet.MimeMultipart)

有错误找到错误原因以及发现值得收藏的一篇文章,方便自己查找。

——————————————————————————————————

错误原因:
需要mail.jar和activation.jar。

Solution:
Web Services Required Jars Download Instructions
http://www.eclipse.org/webtools/wst/components/ws/download_instructions_for_jars.html

解决办法:
1) 下载javamail和jaf,解压出mail.jar和activation.jar
http://java.sun.com/products/javamail/downloads/index.html
http://java.sun.com/products/javabeans/glasgow/jaf.html#download
或者我提供了一个rar包:包含mail.jar action.jar
download:
mail.jar and activation.jar
2) 把mail.jar和activation.jar放到%AXIS_HOME%/WEB-INF/lib目录下

3) 将.jar文件添加到%CLASSPATH%

说明:

这个是可以忽略的。不过以后构建web services都要用到的,还是添加上的好。
参考:http://www.ogsadai.org.uk/documentation/ogsadai-wsi-2.1/doc/wsi/FAQ.html
This is a warning message that can safely be ignored. It is displayed when Axis has been deployed without an optional JAR. An optional JAR is one that allows Axis to support a particular piece of functionalty but is not required for general use. Please refer to the Axis documentation for more details.

备注:
一篇很好的jars下载指南:Web Services Required Jars Download Instructions
Axis指南:Guide to building Axis

 


原文链接:http://blog.csdn.net/llhhyy1989/article/details/8208274
加载中
返回顶部
顶部