ubuntu下eclipse打开java文件,注释内容为乱码,解决方法

长平狐 发布于 2012/11/01 11:49
阅读 382
收藏 0
    由于要转到linux下开发,之前的项目我是用GBK编码得,因为windows默认编码是GBK,但在Linux下默认编码却是UTF-8,所以项目跑步起来,一开始想法是把Linux系统得源码换掉改为GBK,试了网上改系统编码的,就是在系统变量那里设置了一下。然后重启。就登陆不进去Ubuntu了,原因何在?网上又有一大堆是说我把编码改掉了。后来在windows找找解决办法。
第一:/usr/bin/sudo /usr/bin/vi /etc/profile 这里用带完整路径,否则不能识别命令 如果在environment里设置了也要打开进行下面得操作。
第二:输入dd删除与编码相关的行
第三:按shift,输入:,输入wq。进行保存
这样子就可以重新进入ubuntu了。哎。搞了一个多钟得时间。。。

这个办法没解决,还有其他办法可以解决。刚好看到一篇文章介绍。哈哈。借鉴一下。

今天打开了以前的工程,想看看以前写的代码,打开后发现以前的java源文件的注释变成了乱码,于是在google上开始了搜索,得到了结论:
问题出现的原因:因为windows下默认的编码是GBK,在ubuntu下是UTF-8所以,所以在windows下的注释,在ubuntu下就变成了乱码。
解决方法,共有两种:
将ubuntu的系统编码变为GBK,这样和windows的编码就一致了,但是我用这种方法没有成功。
执行命令
sudo vi /etc/environment
然后将文件改为:
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games"
LANGUAGE="zh_CN:zh:en_US:en"
#system code utf-8
#LANG="zh_CN.UTF-8"
#下面将系统默认的编码改为GBK
GST_ID3_TAG_ENCODING=GBK
LANG=zh_CN.GBK
LC_CTYLE=zh_CN.GBK
重启ubuntu就可以了。但是我没有实验成功,不知道为什么?如果有人知道,请在blog留言,告诉我一下。

2. 第二种方法
1) eclipse->window->preferences->General->Content Types
2) 找到要修改的文件的类型,在下面有个Default encoding,在输入框中输入GBK
3) 点击Update
4) 点击OK
5) 重启eclipse
打开源文件,哎呀妈呀,不乱码了!
引用:http://blog.csdn.net/lostpen/archive/2008/12/02/3428624.aspx

原文链接:http://blog.csdn.net/weasleyqi/article/details/7003185
加载中
返回顶部
顶部