android调用高版本api函数的兼容性问题

长平狐 发布于 2013/12/25 17:20
阅读 954
收藏 0

有时候代码中调用的一些api函数对api版本有要求,比如ListView的smoothScrollToPosition函数,该函数要求android api版本在8或者以上才可以使用,即要求用户的手机必须是android2.2及其以上的才行。有些同学可能会这么做

		try
		{
			final int mVersionCode = Integer.valueOf(android.os.Build.VERSION.SDK);
			Logger.d(TAG, "sdk version=" + mVersionCode);
		} 
		catch (Exception e) 
		{
			e.printStackTrace();
		}				if(mVersionCode >= 8){
					mListView.smoothScrollToPosition(position);}

实际上,上述做法是不行的,在android1.6上就会崩溃,错误为找不到smoothScrollToPosition函数,确切来说,在android2.0以下都会崩溃,原因为java虚拟机启动程序的时候就会检查类信息。

解决办法如下(因为android的内部类是运行的时候动态加载的)

				if(mVersionCode >= 8){
				new Object() {
			     public void smoothScrollToPosition(ListView mListView, int position)
			    {
			            mListView.smoothScrollToPosition(position);
			    }
			    }.smoothScrollToPosition(mListView,position);
			    }



 


原文链接:http://blog.csdn.net/singwhatiwanna/article/details/8863710
加载中
返回顶部
顶部