在Ubuntu12.04上部署CloudFoundry-ng (二) uaa和cloud_controller_ng的部署

长平狐 发布于 2013/11/25 18:35
阅读 417
收藏 0

 uaa和cloud_controller_ng的部署


1. 安装并配置UAA(认证模块)



安装jdk


安装maven:
sudo apt-get install mvn


获取uaa的最新源码:
git clone https://github.com/cloudfoundry/uaa.git


为uaa安装独立的ruby和gemset环境(使用rvm)
cd uaa
rvm gemset create uaa
创建.rvmrc文件,写入:“use 1.9.3@uaa”


安装uaa:
bundle install


修改配置文件config/uaa.yml,添加内容:
oauth:
  client:
    override: true
    autoapprove:
      - cf
  clients:
    cf:
      override: true
      authorized-grant-types: password,implicit
      authorities: uaa.none
      scope: cloud_controller.read,cloud_controller.write,openid,password.write,cloud_controller.admin,scim.read,scim.write


jwt:
  token:
    signing-key: 'tokensecret'
    verification-key: 'tokensecret'
scim:
  userids_enabled: false
  user.override: true
  users:
    - admin|admin|scim.write,scim.read,openid,cloud_controller.admin
    - testuser|testuser|scim.write,scim.read,openid,cloud_controller.user
注意.yml文件对缩进敏感,缩进统一使用双空格


运行uaa:
在uaa源码目录下运行:CLOUD_FOUNDRY_CONFIG_PATH=./config/ /usr/bin/mvn tomcat:run






2. 部署cloud_controller_ng


下载最新源码:
git clone https://github.com/cloudfoundry/cloud_controller_ng.git


为controller安装独立的ruby和gemset环境(使用rvm)
cd cloud_controller_ng
rvm gemset create controller_ng
创建.rvmrc文件,写入:“use 1.9.3@controller_ng”


部署cloud_controller_ng:
git submodule update --init --recursive
bundle install
bundle过程中可能遇到错误,一般是缺少/版本不匹配 gem包
比如:提示gem install debugger -v 1.5.0失败,原因其实是Gemfile.lock中规定要安装的依赖debugger-ruby_core_source (1.2.0)与debugger 1.5.0不匹配,修改Gemfile.lock中的debugger-ruby_core_source (1.2.0) 为debugger-ruby_core_source (1.2.2),问题解决。


配置:
在配置文件config/cloud_controller.yml中修改nats_uri为正确的nats地址
bundle exec rake db:migrate


启动cloud_controller:
bundle exec ./bin/cloud_controller -m


3. 安装客户端cf与controller交互:
gem install --version "0.6.1.rc5" cf


cf target http://127.0.0.1:8181


cf login
    Email> admin
    Password> admin



原文链接:http://blog.csdn.net/sraing/article/details/8934091
加载中
返回顶部
顶部