在VMware下安装iphone开发环境(mac10.5.5+iphone sdk 3.0)

鉴客 发布于 2011/11/21 23:39
阅读 2K+
收藏 1

为了学习objective—c,不得不安装xcode。为了安装xcode,不得不接触mac操作系统。

早就听说iso开发的成本,一台mac+iphone,无奈本人没有这个资金,所以只有借助强大的百度和谷歌,看看有没有其他的手段,现实这个环境。以前从来没有接触iphone也没有接触mac系统,基本上算白痴一个。网上的虚拟机教程一大推,说的都很不明白,看不懂。而且什么虚拟化,什么的64位,什么什么的~~~一大堆配置,感觉稍有失误就会粉身碎骨。所以在决定在虚拟机上弄一个mac系统时,我就专门搜集了大量的资料和访问了大量的在线网友,QQ 好友,mac技术交流群。可是得出的结论还是很不明白。难道就没有一个方便快捷的,不要考虑那么多那么多复杂问题的安装方法??

经过本人坚强的装机实战,终于得出了一套完美的装机方法,基本上可以说是傻瓜式的。下面就将 我的装机过程和大家分享,以免大家重蹈我的覆辙。

(本人可是苦战了好几天,研究了n多得资料得出的宝贵的经验哦!)

首先用一个securable.exe的工具得出我台式机的性能:

N多得热心网友看见我这张报告时,都劝我放弃虚拟机装mac的念头,不支持虚拟化的cpu是不可能运行mac起来的,本人先开始也是准备换一个CPU,

但是抱着试试的心态,还是依然下载好了VMware Workstation,这个版本是7.1.4的吧!下载之后,就去找mac的镜像,经过热心网友的指引,我到verycd

下找到一个,不用安装的镜像文件!http://www.verycd.com/topics/2751087/,这是电驴的地址,下载好这个之后点击里面的

启动mac os x 那个,就可以直接在虚拟机里面启动了。不管你的CPU支不支持虚拟化,反正我的是不支持虚拟化的,但是也跑起来了。

mac环境起来了,下面我们要做的是帮xcode装到这个系统里面,其实mac10.5.5是个很老的版本,流行在09的那个时候,我的机子是09年买的,相对来说跑高版本的mac很吃力,再说也找不到比这个更好的镜像文件了,verycd上还有一个配置好的镜像文件,版本是10.7的,是个比较新的版本,但是看评论说装的都跑不起来,所以没有敢尝试。有兴趣的朋友可以拿到自己电脑试试看,附上网址http://www.verycd.com/topics/2897839/

10.5.5这个版本 貌似说支持Xcode3.0,但是又貌似不能。我用10.5.5这个。在不伪装的情况下,装过一次Xcode3.0.在安装的一个半小时左右,XP虚拟机出现内存错误。很受挫折,于是彻底的伪装了系统。帮系统伪装成:10.5.7这个版本的mac

伪装后,成为10.5.7了。  恩!这个只能装iphone sdk 3.0,也就是xcode 3.0.其他版本的,我试过 都不行,即使伪装系统到10.6以上,提示可以安装了,但是xcode也是跑步起来的!iphone sdk 3.0,可以去csdn下载,还是蛮多的!

下面介绍下 系统的伪装,伪装10.5.7是可以的!其他的貌似不行,感兴趣的朋友可以自己去尝试。

 

1,下载iPhone SDK安装包:iphone_sdk_3.0__leopard__9m2736__final.dmg(官网下载)
2,更改10.5.5系统版本信息:
1)找到 :/系统盘/system/library/coreservices/SystemVersion.plist
2) 打开,将其修改为:

3)保存前,更改该文件及其所在目录的属性为可读写read &write
3,安装iPhone Sdk 3.0
4,助你成功!

(注意了,我们用的10.5.5是中文版的!上面的路径是英文的,大家注意找找,不要找不到SystemVersion.plist,还有我提供的这个10.5.5的密码是memac.cn
,不是www.memac.cn,千万注意了!!!!!!!!!!)。

 

恩!很多朋友不知道怎样帮iphone_sdk_3.0引入到mac虚拟机中,其实只要设置虚拟机的光驱到iphone_sdk_3.0的路径就可以了。很简单的!设置好了后。mac系统就会自己弹出这个假光驱里面的内容。我们就可以安装iphone_sdk_3.0啦!

原文链接:http://blog.csdn.net/wanli_smile/article/details/6954256

加载中
返回顶部
顶部