SecureCRT连接Linux时VIM中文乱码

鉴客 发布于 2011/10/25 10:24
阅读 2K+
收藏 1

在SecureCRT连接Linux机器进行程序文件和配置编辑时,经常会遇到各种乱码问题:

1、Linux下的文本显示有乱码;

2、即使显示出来没有乱码,将文本复制粘贴到其他windows程序中也会是乱码,

3、或者从windows复制文件到Linux下,SecureCRT打开会乱码,很不方便。

这些问题最终原因是字符编码不一致的问题,可尝试按下面的方法来设置。

Liunx下包含中文的文件在 vim 里面无法正常显示,与下面几个设置有关系 :

  1、所连接的Linux机器 的系统预设的可支持的字符编码集,这与/etc/sysconfig/i18n 有关;

  2、与终端介面的字符编码有关,即bash,这与LANG参数有关

  3、文件本身的字符编码有关

  4、连接到Linux机器的软件SecureCRT的字符编码集有关。

只要第3,4两点设置的字符编码集一致,就可以在Linux下正确的显示和编辑含中文的文件内容,否则就是一堆乱码。

关于SecureCRT的字符编码集的设置:

1. 首先进入 Option 菜单 >> Session Option
2. Terminal >> Emulation,在右边 Terminal下拉菜单中选择"Linux", "ANSI Color"前面打上勾。
3. Terminal >> Appearance,
3.1 点右边的Font 按钮, 1) 选择新宋体,2) 字符集选"中文 GB2312"
3.2 Charactor 下拉菜单中选择 "Default", 去掉"Use Unicode line drawing character"前面的勾。

如果用了上述方法后,还是出现乱码,那有可能就是secureCRT字体设置的问题了
不会有乱码的是:fixedsys,新宋体,宋体
会出现乱码的是:vt100,courier,courier new
如果你也是上述原因,建议把字体换换,换成fixedsys吧。

文章出处:http://blog.csdn.net/fengxinze/article/details/6869029

加载中
返回顶部
顶部