整合 ECShop2.7.2 与 Discuz!6.0

鉴客 发布于 2011/09/21 14:44
阅读 730
收藏 0

1. 安装ECShop2.7.2

a)   推荐配置:LAMPLinux+Apache+Mysql+PHP

操作系统:Linux (支持Unix/FreeBSD/Solaris/Windows NT(2000/2003)等操作系统)

WEB服务器:Apache (支持httpd, Zeus, IIS WEB服务器)

数据库:Mysql (3.23 或者更高版本)程序支持:PHP 4.3.0及以上版本 (推荐使用5.2系列最新版本)

b)  下载ECShop2.7.2  http://www.ecshop.com/download.php

c)   安装准备

i.   Windows系统环境下

1.   下载xampp软件,选择安装路径,next直到安装完毕。若出现apache无法正常使用,请参照http://lonelystarxing.javaeye.com/blog/870975解决。

2.   将下载好的ECSHOP最新软件包解压缩到Z:\xampp\htdocs中。将upload文件夹重命名为ecshopwindows系统默认设置文件及文件夹的权限为777,无需做修改。

3.   现在可在浏览器中访问http://localhost/ECShop/ecshop即可在本机开始按照提示配置属于你的ecshop

ii.   Linux系统环境下

1.   解压上传到服务器,本次使用/var/www,upload文件夹重命名为ecshop

2.   修改目录权限。

a)   存在www文件夹无权限访问,可以使用sudo chmod R 777 www修改权限后即可上传。

b)  使用chmod修改如下目录及其所有子目录权限

i.   Data/目录及其所有子目录

ii.   temp/ 目录及其所有子目录

iii.   cert/ 目录

 iv.   includes/ 目录及其所有子目录

   v.   images/ 目录及其所有子目录

 vi.   themes/ 目录及其所有子目录

3.   在浏览器中访问http://localhost/ECShop/ecshop即可在本机开始按照提示配置属于你的ecshop

d)  安装程序

i.   条款意向

ii.   环境与目录权限监测

   iii.   设置数据库与管理账号及其他杂项

iv.   安装完毕

e)  

2.    安装Discuz!6.0

a)  语言及数据库要求

i.   可用的 httpd 服务器(如 Apache, Zeus, IIS 等)

  ii.   php 4.1.0 及以上

   iii.   Zend Optimizer 3.0及以上

  iv.   MySQL 3.23 及以上(仅针对 MySQL Discuz!

b)  下载Discuz6.0 www.discuz.net

c)  安装准备

d)  参照ECShop安装准备

i.   注:linux下需要修改权限的文件或者文件夹为

1.config.inc.php

2../templates

3../attachments

4../customavatars

5../forumdata

6../forumdata/templates

7../forumdata/cache

8../forumdata/threadcaches

9../forumdata/logs

e)  安装程序

i.   在浏览器中运行install.php进入准备安装页面,阅读许可协议  http://web服务器地址/文件/install.php

  ii.   同意后进入环境检查,修改权限

   iii.   数据库信息配置

  iv.   填写管理员账号密码

v.   安装程序,建立数据库

  vi.   完成

3.     ECShop后台整合Discuz

a)  进入ECShop后台管理

b)  菜单->会员管理->会员整合

c)  点击Discuz后面的安装,进入设置整合插件页面

d)  填写相关信息

注:COOKIE前缀可以通过登录Discuz调试器(如firebug)或者config.inc.php文件查看后填写。

e)  下一步 进入检查商城用户是否与论坛用户用重名情况及处理方法选择。

f)  下一步 检查。

g)  开始任务 进行整合保证数据同步。

h)  完成。

加载中
返回顶部
顶部