解决64位Linux运行32位程序的问题

小编辑 发布于 2010/05/12 08:50
阅读 2K+
收藏 0

apt-get install ia32-libs

如果提示bash: ./test: cannot execute binary file

则可能是内核中没有编译进32位的兼容

 Executable file formats / Emulations

 [*] Kernel support for ELF binaries        

 [ ] Write ELF core dumps with partial segments
 <*> Kernel support for MISC binaries       
 [*] IA32 Emulation                         
 <M>   IA32 a.out support                   

 编译进这几个模块就可以使用啦

加载中
返回顶部
顶部