[转] Tokyo Tyrant 安装日志

小编辑 发布于 2011/01/05 14:43
阅读 803
收藏 3

tokyo tyrant是一个可持久化的缓存服务器,类似memcachedb,tokyo tyrant本身是个缓存服务器,但需要tokyo cabinet作为存储引擎,

就像memcachedb中的memcache需要berkeley db一样

1)安装存储引擎tokyo cabinet

 

wget http://1978th.net/tokyocabinet/tokyocabinet-1.4.42.tar.gz
tar xzvf tokyocabinet-1.4.42.tar.gz
cd tokyocabinet-1.4.42
./configure --prefix=/path/to/tokyocabinet

报错: 

configure: error: bzlib.h is required

解决

sudo apt-get install libbz2-dev  

然后

./configure --prefix=/path/to/tokyocabinet make sudo make install

2)安装toyko tyrant

 

wget http://1978th.net/tokyotyrant/tokyotyrant-1.1.40.tar.gz
tar xzvf tokyotyrant-1.1.40.tar.gz
cd tokyotyrant-1.1.40
./configure --prefix=/path/to/tokyotyrant --enable-lua

出错: 

configure: error: tcutil.h is requiredconfigure: error: tcutil.h is required

解决

./configure --prefix=/path/to/tokyotyrant --with-tc=/path/to/tokyocabinet --enable-lua

再次报错

configure: error: lua.h is required

解决

2.1)安装lua(此步骤可选,可在安装是不要--enable-lua这个选项)

wget http://www.lua.org/ftp/lua-5.1.4.tar.gz   
tar zxf lua-5.1.4.tar.gz
cd lua-5.1.4
make linux

发现问题:

luaconf.h:275:31: error: readline/readline.h: 没有该文件或目录
luaconf.h:276:30: error: readline/history.h: 没有该文件或目录

解决 

sudo apt-get install libreadline5-dev

最后

make linux  
sudo make install  

可以看到,lua 的 include 和lib位于/usr/local下 

2.2)继续安装

./configure --prefix=/path/to/tokyotyrant --with-tc=/path/to/tokyocabinet --enable-lua
make
sudo make install

3) 测试

3.1)演示非持久性 

3.1.1)启动服务: 

bin/ttserver

 

3.1.2)使用客户端

另起一个终端

存放: bin/tcrmgr put localhost one first

获取: bin/tcrmgr get localhost one

得到结果 first

 

3.2.3)测试持久

重启ttserver,再次获取bin/tcrmgr get localhost one

没有结果 

 

3.2)演示持久性 

3.2.1)启动服务

bin/ttserver /tmp/x.tch

 

3.2.2)使用客户端

另起一个终端

存放: bin/tcrmgr put localhost one first
获取: bin/tcrmgr get localhost one

 

3.2.3)测试持久

重启ttserver 

再次获取:

bin/tcrmgr get localhost one

ok

加载中
返回顶部
顶部