Ubuntu Linux下Flex 4开发环境的搭建

小编辑 发布于 2010/08/01 07:12
阅读 1K+
收藏 1

Flex 3 应该也可以。Adobe labs有一个这样的项目:Flex Builder 3 for Linux ,没试。

我的环境是 Ubuntu 10.04

Flex 4官方没有Linux版本 理论上可以将Window下的Flash Builder移植到Linux下面来。既然Adobe不愿意做,eshangrao 给大家给了一个

1.首先冲上eclipse官方下了一个eclipse-jee-helios-linux-gtk.tar.gz  解压即可

2.整了个jdk-6u10-linux-i586.bin

3.装好jdk配置环境 sudo gedit /etc/profile

在最后面加上

JAVA_HOME=/home/liucf/dev/jdk1.6.0_10

export JRE_HOME=/home/liucf/dev/jdk1.6.0_10/jre

export CLASSPATH=.:$JAVA_HOME/lib:$JRE_HOME/lib:$CLASSPATH

export PATH=$JAVA_HOME/bin:$JRE_HOME/bin:$PATH

路径注意

source /etc/profile后 java -version能看到版本信息

本人小菜。不知道如何让配置文件生效   于是乎重启电脑即可。

4.去 这里 下载 FB4Linuxaa、FB4Linuxab、FB4Linuxac、FB4Linuxad、 FB4Linuxae、FB4Linuxaf并放在同一个文件夹,然后执行:cat FB4Linux* >FB4Linux.tar.bz2

将FB4Linux.tar.bz2解压放至eclipse dropins文件夹即可

5.重启eclipse生效。问题:无预览视图,不能双击打断点,但可以右键添加断点(原因不明)

6.调试环境firefox 或者 chrome   参考这里。官方下回来的解压是一个libflashplayer.so

6.1 firefox

tar xvf install_flash_player_10_linux.tar.gz

cd install_flash_player_10_linux

sudo cp libflashplayer.so /usr/lib/mozilla/plugins/

6.2 chrome

将/opt/google/chrome/下面的 libgcflashplayer.so 干掉。然后将下回来的 libflashplayer.so 改名成 libgcflashplayer.so   copy到/opt/google/chrome/

7.AIR支持

若需要运行和调试AIR项目,会出现错误提示:

!ApolloLaunchDelegate.dirDoesNotExist!

原因是从opensource.adobe.com下载的FlexSDK不包含Linux编译器,必须使用Linux版本的AIR SDK。

根据自己的需要和安装的AIR运行时版本,从下面的链接下载:

AIR SDK 2

解压缩下载的内容并将其覆盖到你的Flex SDKS文件夹。

同时,应安装AIR Runtime

8.调试的时候可能出现

到 file:///home/liucf/dev/workspace/test/bin-debug /framework_4.0.0.14159.swf 的连接已停止 - 不允许从 file:///home/liucf/dev/workspace/test/bin-debug/test.swf 进行连接

SecurityError: Error #2148: SWF 文件 file:///home/liucf/dev/workspace/test/bin-debug/test.swf 不能访问本地资源 file:///home/liucf/dev/workspace/test/bin-debug /framework_4.0.0.14159.swf。只有仅限于文件系统的 SWF 文件和可信的本地 SWF 文件可以访问本地资源。

at flash.net::URLStream/load()

at flash.net::URLLoader/load()

at mx.core::CrossDomainRSLItem/load()[E:\dev\4.0.0\frameworks\projects\framework\src\mx\core\CrossDomainRSLItem.as:240]

at mx.core::RSLListLoader/loadNext()[E:\dev\4.0.0\frameworks\projects\framework\src\mx\core\RSLListLoader.as:184]

at mx.core::RSLListLoader/load()[E:\dev\4.0.0\frameworks\projects\framework\src\mx\core\RSLListLoader.as:156]

at mx.preloaders::Preloader/initialize()[E:\dev\4.0.0\frameworks\projects\framework\src\mx\preloaders\Preloader.as:279]

at mx.managers::SystemManager/http://www.adobe.com/2006/flex/mx/internal::initialize()[E:\dev\4.0.0\frameworks\projects\framework\src\mx\managers\SystemManager.as:1925]

rsl 问题。。将工程构建改成非rsl即可

或者:flex项目上点右键-->properties-->ActionscriptCompiler-->Additional compiler arguments

加上  “  -use-network=false ”

fb4linux 项目也有解决方案:try to add the eclipse workspace path to ~/.macromedia/Flash_Player/#Security/FlashPlayerTrust/flexbuilder_plugin.cfg  意思是将你的工程路径加入到 flexbuilder_plugin.cfg这个文件中  比如test工程   /home/liucf/dev/workspace/test

加载中
0
l
liucf

  转载的文章为什么没有出处  原文:http://deeplyloving.iteye.com/blog/726217

返回顶部
顶部